Project

General

Profile

Bug #56411

Workaround for ceph-mgr breaks Cython builds

Added by Adam Emerson 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
pacific, quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

FAILED: lib/cython_modules/lib.3/rados.cpython-310-x86_64-linux-gnu.so /home/aemerson/work/ceph/repo/build/lib/cython_modules/lib.3/rados.cpython-310-x86_64-linux-gnu.so
cd /home/aemerson/work/ceph/repo/src/pybind/rados && env CC="/usr/bin/cc" CFLAGS="-fno-var-tracking-assignments" CPPFLAGS="-iquote/home/aemerson/work/ceph/repo/src/include -w -D'void0=dead_function(void)' -D'__Pyx_check_single_interpreter(ARG)=ARG ## 0'" CXX="/usr/bin/c++" LDSHARED="/usr/bin/cc -shared" OPT="-DNDEBUG -g -fwrapv -O2 -w" LDFLAGS=-L/home/aemerson/work/ceph/repo/build/lib CYTHON_BUILD_DIR=/home/aemerson/work/ceph/repo/build/src/pybind/rados CEPH_LIBDIR=/home/aemerson/work/ceph/repo/build/lib /usr/bin/python3.10 /home/aemerson/work/ceph/repo/src/pybind/rados/setup.py build --build-base /home/aemerson/work/ceph/repo/build/lib/cython_modules --build-platlib /home/aemerson/work/ceph/repo/build/lib/cython_modules/lib.3
Compiling rados.pyx because it changed.
[1/1] Cythonizing rados.pyx
running build
running build_ext
building 'rados' extension
C compiler: /usr/bin/cc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fno-var-tracking-assignments -iquote/home/aemerson/work/ceph/repo/src/include -w -Dvoid0=dead_function(void) -D__Pyx_check_single_interpreter(ARG)=ARG ## 0 -fPIC

creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo/build
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo/build/src
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo/build/src/pybind
creating /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo/build/src/pybind/rados
compile options: '-I/usr/include/python3.10 -I/usr/include/python3.10 -c'
extra options: '-Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fno-var-tracking-assignments -iquote/home/aemerson/work/ceph/repo/src/include -w -Dvoid0=dead_function(void) -D__Pyx_check_single_interpreter(ARG)=ARG ## 0 -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2'
cc: /home/aemerson/work/ceph/repo/build/src/pybind/rados/rados.c
cc: warning: ##: linker input file unused because linking not done
cc: error: ##: linker input file not found: No such file or directory
cc: warning: 0: linker input file unused because linking not done
cc: error: 0: linker input file not found: No such file or directory
error: Command "/usr/bin/cc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -w -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fno-var-tracking-assignments -iquote/home/aemerson/work/ceph/repo/src/include -w -Dvoid0=dead_function(void) -D__Pyx_check_single_interpreter(ARG)=ARG ## 0 -fPIC -I/usr/include/python3.10 -I/usr/include/python3.10 -c /home/aemerson/work/ceph/repo/build/src/pybind/rados/rados.c -o /home/aemerson/work/ceph/repo/build/lib/cython_modules/temp.linux-x86_64-3.10/home/aemerson/work/ceph/repo/build/src/pybind/rados/rados.o -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fno-var-tracking-assignments -iquote/home/aemerson/work/ceph/repo/src/include -w -Dvoid0=dead_function(void) -D__Pyx_check_single_interpreter(ARG)=ARG ## 0 -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2" failed with exit status 1
[818/1486] Building CXX object src/tools/ceph-dencoder/CMakeFiles/denc-mod-common.dir/common_types.cc.o
ninja: build stopped: subcommand failed.

Something is breaking the spacing here. This is with Python 3.10.

I get the same error whether I use make or ninja.

gcc (Debian 11.3.0-3) 11.3.0

/bin/sh is bash.

Cython version 0.29.30

This is directly from the bit of magic in Distutils.cmake that wipes out __Pyx_check_single_interpreter() , since if I remove that everything works.

(But I don't want to break ceph-mgr, so I can't really commit that.)

History

#1 Updated by Adam Emerson 3 months ago

  • Status changed from New to Closed

Also available in: Atom PDF