Project

General

Profile

Bug #56175

ERROR: rgw_multi.tests.test_role_sync

Added by Casey Bodley 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
% Done:

0%

Source:
Tags:
multisite sts
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

from http://qa-proxy.ceph.com/teuthology/aemerson-2022-06-17_18:41:43-rgw-wip-timestamp-status-distro-default-smithi/6884596/teuthology.log

2022-06-17T20:20:36.281 INFO:tasks.rgw_multisite_tests:======================================================================
2022-06-17T20:20:36.282 INFO:tasks.rgw_multisite_tests:ERROR: rgw_multi.tests.test_role_sync
2022-06-17T20:20:36.282 INFO:tasks.rgw_multisite_tests:----------------------------------------------------------------------
2022-06-17T20:20:36.283 INFO:tasks.rgw_multisite_tests:Traceback (most recent call last):
2022-06-17T20:20:36.284 INFO:tasks.rgw_multisite_tests:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_31a356e0c737f1781079045bb8dc366982be8713/virtualenv/lib/python3.6/site-packages/nose/case.py", line 198, in runTest
2022-06-17T20:20:36.284 INFO:tasks.rgw_multisite_tests:    self.test(*self.arg)
2022-06-17T20:20:36.285 INFO:tasks.rgw_multisite_tests:  File "/home/teuthworker/src/git.ceph.com_ceph-c_31252a7818c25c4b1c9b7cc6f8d623437628fc6c/qa/../src/test/rgw/rgw_multi/tests.py", line 1703, in test_role_sync
2022-06-17T20:20:36.285 INFO:tasks.rgw_multisite_tests:    check_role_eq(source_conn, target_conn, role)
2022-06-17T20:20:36.286 INFO:tasks.rgw_multisite_tests:  File "/home/teuthworker/src/git.ceph.com_ceph-c_31252a7818c25c4b1c9b7cc6f8d623437628fc6c/qa/../src/test/rgw/rgw_multi/tests.py", line 603, in check_role_eq
2022-06-17T20:20:36.286 INFO:tasks.rgw_multisite_tests:    zone_conn2.check_role_eq(zone_conn1, role['create_role_response']['create_role_result']['role']['role_name'])
2022-06-17T20:20:36.287 INFO:tasks.rgw_multisite_tests:AttributeError: 'ZoneConn' object has no attribute 'check_role_eq'
2022-06-17T20:20:36.288 INFO:tasks.rgw_multisite_tests:-------------------- >> begin captured logging << --------------------

History

#1 Updated by Pritha Srivastava 5 months ago

This test runs fine locally for me. Checking it in teuthology now.

#2 Updated by Casey Bodley 5 months ago

it looks like this is only failing in the realms/three-zone-plus-pubsub configuration, so it's probably the pubsub zone in test/rgw/rgw_multi/zone_ps.py that's missing check_role_eq()

if you add 'num_ps_zones = 1' to your RGW_MULTI_TEST_CONF, you should be able to reproduce it locally

#3 Updated by Casey Bodley 5 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 46887

#4 Updated by Casey Bodley 5 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF