Project

General

Profile

Bug #55778

client: choose auth MDS for getxattr with the Xs caps

Added by Xiubo Li 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client
Labels (FS):
task(medium)
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This run: https://pulpito.ceph.com/vshankar-2022-04-11_12:24:06-fs-wip-vshankar-testing1-20220411-144044-testing-default-smithi/6786559/

None of the PRs in the branch seem to be causing this and its not easily reproducible.

pjd fails in:

2022-04-13T04:59:41.926 INFO:tasks.workunit.client.0.smithi167.stderr:+ ntest=80
2022-04-13T04:59:41.926 INFO:tasks.workunit.client.0.smithi167.stderr:+ expect u::r--,u:root:r-x,u:65531:rwx,g::r--,g:root:rw-,g:65532:rwx,m::rwx,o::r-- getfacl fstest_73fed23d6d34bccdc1d73b05e3d22103/fstest_da3b235a078085ef61f2cae3419311a2 access
2022-04-13T04:59:41.926 INFO:tasks.workunit.client.0.smithi167.stderr:+ e=u::r--,u:root:r-x,u:65531:rwx,g::r--,g:root:rw-,g:65532:rwx,m::rwx,o::r--
2022-04-13T04:59:41.926 INFO:tasks.workunit.client.0.smithi167.stderr:+ shift
2022-04-13T04:59:41.927 INFO:tasks.workunit.client.0.smithi167.stderr:++ /home/ubuntu/cephtest/mnt.0/client.0/tmp/tmp/../pjd-fstest-20090130-RC/tests/xacl/../../fstest getfacl fstest_73fed23d6d34bccdc1d73b05e3d22103/fstest_da3b235a078085ef61f2cae3419311a2 access
2022-04-13T04:59:41.927 INFO:tasks.workunit.client.0.smithi167.stderr:++ tail -1
2022-04-13T04:59:41.928 INFO:tasks.workunit.client.0.smithi167.stderr:+ r=u::r--,u:root:r-x,g::r--,g:root:rw-,m::r-x,o::r--
2022-04-13T04:59:41.928 INFO:tasks.workunit.client.0.smithi167.stderr:+ echo u::r--,u:root:r-x,g::r--,g:root:rw-,m::r-x,o::r--
2022-04-13T04:59:41.929 INFO:tasks.workunit.client.0.smithi167.stderr:+ egrep '^u::r--,u:root:r-x,u:65531:rwx,g::r--,g:root:rw-,g:65532:rwx,m::rwx,o::r--$'
2022-04-13T04:59:41.929 INFO:tasks.workunit.client.0.smithi167.stderr:+ '[' 1 -eq 0 ']'
2022-04-13T04:59:41.929 INFO:tasks.workunit.client.0.smithi167.stderr:+ echo 'not ok 80'


Related issues

Copied from CephFS - Bug #55331: pjd failure (caused by xattr's value not consistent between auth MDS and replicate MDSes) Resolved
Copied to CephFS - Backport #56109: quincy: client: choose auth MDS for getxattr with the Xs caps Resolved
Copied to CephFS - Backport #56110: pacific: client: choose auth MDS for getxattr with the Xs caps Resolved

History

#1 Updated by Xiubo Li 6 months ago

  • Copied from Bug #55331: pjd failure (caused by xattr's value not consistent between auth MDS and replicate MDSes) added

#3 Updated by Xiubo Li 6 months ago

Xiubo Li wrote:

This will fix the following two bugs:

https://tracker.ceph.com/issues/55240
https://tracker.ceph.com/issues/55331

The kclient has fixed them already.

#4 Updated by Xiubo Li 6 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 46412
  • Component(FS) Client added

#5 Updated by Venky Shankar 6 months ago

Xiubo Li wrote:

Xiubo Li wrote:

This will fix the following two bugs:

https://tracker.ceph.com/issues/55240
https://tracker.ceph.com/issues/55331

The kclient has fixed them already.

Right - this doesn't really fix tracker #55240, isn't it?

#6 Updated by Xiubo Li 6 months ago

Venky Shankar wrote:

Xiubo Li wrote:

Xiubo Li wrote:

This will fix the following two bugs:

https://tracker.ceph.com/issues/55240
https://tracker.ceph.com/issues/55331

The kclient has fixed them already.

Right - this doesn't really fix tracker #55240, isn't it?

The tracker #55240 has two issues when going through the logs:

1, mds: stuck 2 seconds and keeps retrying to find ino from auth MDS as the title says.

2, Choosing random MDSes for getattr when the x caps is issued. I have fixed in kclient already in https://github.com/ceph/ceph-client/commit/5eed80fba65cd707075892450bc5d6bd464862a0, and this PR will fix it in libcephfs.

#7 Updated by Venky Shankar 6 months ago

  • Status changed from Fix Under Review to Pending Backport

#8 Updated by Backport Bot 6 months ago

  • Copied to Backport #56109: quincy: client: choose auth MDS for getxattr with the Xs caps added

#9 Updated by Backport Bot 6 months ago

  • Copied to Backport #56110: pacific: client: choose auth MDS for getxattr with the Xs caps added

#10 Updated by Xiubo Li 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF