Project

General

Profile

Backport #55201

cephadm/monitoring: monitoring stack versions are too old

Added by Ernesto Puerta 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Target version:
Release:
Crash signature (v1):
Crash signature (v2):

Description

cephadm is deploying old versions of prometheus, alertmanager, node-exporter, which constrains the features that can be utilised when managing and monitoring the cluster.

Recommend updating to

Prometheus 2.18 -> 2.28
Alertmanager 0.20 -> 0.23
node-exporter 0.18.1 -> 1.3.0

the target versions above are given as a guide only - testing is needed to confirm compatibility


Subtasks

Bug #55202: grafana/Makefile: don't push image to dockerDuplicateErnesto Puerta

Bug #55203: monitoring/grafana: fix Grafana versionResolvedErnesto Puerta

Cleanup #55204: mgr/dashboard: update grafana piechart and vonage status panel versionsDuplicateAashish Sharma


Related issues

Copied from Orchestrator - Bug #54311: cephadm/monitoring: monitoring stack versions are too old Resolved

History

#1 Updated by Ernesto Puerta 8 months ago

  • Copied from Bug #54311: cephadm/monitoring: monitoring stack versions are too old added

#3 Updated by Ernesto Puerta 8 months ago

  • Status changed from New to In Progress

#4 Updated by Yuri Weinstein 8 months ago

Ernesto Puerta wrote:

https://github.com/ceph/ceph/pull/45799

merged

#5 Updated by Ernesto Puerta 8 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF