Project

General

Profile

Bug #55195

Orchestrator - Bug #54311: cephadm/monitoring: monitoring stack versions are too old

mgr/dashboard: update grafana piechart and vonage status panel versions

Added by Aashish Sharma 10 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
Monitoring
Target version:
% Done:

100%

Source:
Tags:
Backport:
pacific quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

update grafana piechart and vonage status panel versions to make them compatible with the latest grafana version(8.3.5)


Related issues

Duplicated by Dashboard - Cleanup #55204: mgr/dashboard: update grafana piechart and vonage status panel versions Duplicate
Copied to Dashboard - Backport #55199: pacific: mgr/dashboard: update grafana piechart and vonage status panel versions Resolved
Copied to Dashboard - Backport #55200: quincy: mgr/dashboard: update grafana piechart and vonage status panel versions Resolved
Copied to Dashboard - Cleanup #55204: mgr/dashboard: update grafana piechart and vonage status panel versions Duplicate
Copied to Dashboard - Cleanup #55369: mgr/dashboard: update grafana piechart and vonage status panel versions Pending Backport

History

#1 Updated by Arthur Outhenin-Chalandre 10 months ago

Hey Aashish,

The piechart plugin is at its latest version (in 2020) and officially deprecated while the status panel didn't get any update since 2 years (and we almost have the latest version by one patch version...). So if it currently doesn't work with the latest version of Grafana it would probably mean that we would have to fix the plugins ourselves and probably even fork them...

I think it would be better that we end up using the official piechart panel instead: https://grafana.com/docs/grafana/v8.3/visualizations/pie-chart-panel/ (there are already binding for that in grafonnet). For the status panel no idea what it's used for in the dashboard but guessing that one of these two panel https://grafana.com/docs/grafana/v8.3/visualizations/status-history/ https://grafana.com/docs/grafana/v8.3/visualizations/state-timeline/ could maybe work?

#2 Updated by Ernesto Puerta 10 months ago

  • Category set to Monitoring
  • Status changed from New to Fix Under Review
  • Assignee set to Aashish Sharma
  • Target version set to v17.0.0
  • Pull request ID set to 45793

#3 Updated by Ernesto Puerta 10 months ago

  • Parent task set to #54311

#4 Updated by Ernesto Puerta 10 months ago

  • Backport set to pacific quincy

#5 Updated by Ernesto Puerta 10 months ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Backport Bot 10 months ago

  • Copied to Backport #55199: pacific: mgr/dashboard: update grafana piechart and vonage status panel versions added

#7 Updated by Backport Bot 10 months ago

  • Copied to Backport #55200: quincy: mgr/dashboard: update grafana piechart and vonage status panel versions added

#8 Updated by Ernesto Puerta 10 months ago

  • Copied to Cleanup #55204: mgr/dashboard: update grafana piechart and vonage status panel versions added

#9 Updated by Aashish Sharma 10 months ago

  • Copied to Cleanup #55369: mgr/dashboard: update grafana piechart and vonage status panel versions added

#10 Updated by Aashish Sharma 9 months ago

Arthur Outhenin-Chalandre wrote:

Hey Aashish,

The piechart plugin is at its latest version (in 2020) and officially deprecated while the status panel didn't get any update since 2 years (and we almost have the latest version by one patch version...). So if it currently doesn't work with the latest version of Grafana it would probably mean that we would have to fix the plugins ourselves and probably even fork them...

I think it would be better that we end up using the official piechart panel instead: https://grafana.com/docs/grafana/v8.3/visualizations/pie-chart-panel/ (there are already binding for that in grafonnet). For the status panel no idea what it's used for in the dashboard but guessing that one of these two panel https://grafana.com/docs/grafana/v8.3/visualizations/status-history/ https://grafana.com/docs/grafana/v8.3/visualizations/state-timeline/ could maybe work?

Hey Arthur I didn't find the official piechart panel support in the grafonnet docs. Its still mentioned there that you explicitly have to install the pie chart plugin. Can you please point me to where can I find the reference to that?

#11 Updated by Arthur Outhenin-Chalandre 9 months ago

Aashish Sharma wrote:

Arthur Outhenin-Chalandre wrote:

Hey Aashish,

The piechart plugin is at its latest version (in 2020) and officially deprecated while the status panel didn't get any update since 2 years (and we almost have the latest version by one patch version...). So if it currently doesn't work with the latest version of Grafana it would probably mean that we would have to fix the plugins ourselves and probably even fork them...

I think it would be better that we end up using the official piechart panel instead: https://grafana.com/docs/grafana/v8.3/visualizations/pie-chart-panel/ (there are already binding for that in grafonnet). For the status panel no idea what it's used for in the dashboard but guessing that one of these two panel https://grafana.com/docs/grafana/v8.3/visualizations/status-history/ https://grafana.com/docs/grafana/v8.3/visualizations/state-timeline/ could maybe work?

Hey Arthur I didn't find the official piechart panel support in the grafonnet docs. Its still mentioned there that you explicitly have to install the pie chart plugin. Can you please point me to where can I find the reference to that?

Oh you are right my bad I thought that it supports the new version included by defaylt, so yeah there is no support for anything in grafonnet apparently... Probably because Grafana want to support cue in the long run (but nothing is really available AFAIK for the moment) :/.

#12 Updated by Ernesto Puerta 8 months ago

  • Duplicated by Cleanup #55204: mgr/dashboard: update grafana piechart and vonage status panel versions added

#13 Updated by Backport Bot 6 months ago

  • Tags set to backport_processed

#14 Updated by Konstantin Shalygin 4 months ago

  • Tracker changed from Cleanup to Bug
  • Status changed from Pending Backport to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (backport_processed)
  • Regression set to No
  • Severity set to 3 - minor

Also available in: Atom PDF