Project

General

Profile

Bug #55

osd: fix transition from snaps -> no snaps -> snaps

Added by Sage Weil over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
Start date:
04/21/2010
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

After filestore btrfs snaps = 1 -> 0, we may have leftover snap dirs. Later, if we turn them back on again, we'll roll back to a horribly ancient state.


Related issues

Blocked by Ceph - Feature #359: osd: use new btrfs snapshot ioctls Resolved 08/17/2010

History

#1 Updated by Sage Weil over 9 years ago

  • Target version changed from v0.21 to v0.22

#2 Updated by Sage Weil about 9 years ago

  • Target version changed from v0.22 to v0.23

#3 Updated by Sage Weil about 9 years ago

I think all we need to do is look at current/commit_op_seq. If it is greater than the newest snap, than that snap is stale, because someone went and committed to current/.

An optional arg --osd-use-stale-snap bool would override that. That way you could still manually roll back to an older snap (by, say, deleting/renaming the newest) if you needed to for some reason.

#4 Updated by Sage Weil about 9 years ago

  • Assignee set to Yehuda Sadeh

#5 Updated by Yehuda Sadeh about 9 years ago

  • Status changed from New to Resolved

#6 Updated by Sage Weil about 9 years ago

  • translation missing: en.field_position deleted (317)
  • translation missing: en.field_position set to 183

Also available in: Atom PDF