Project

General

Profile

Bug #5475

ceph-deploy deb install breaks on i386 due to missing python-pushy package

Added by Ross Turk about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
06/27/2013
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

We're not building python-pushy for i386, so attempts to apt-get install ceph-deploy fail:

rturk@ubuntu:~$ sudo apt-get install ceph-deploy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ceph-deploy : Depends: python-pushy but it is not installable
E: Unable to correct problems, you have held broken packages.
rturk@ubuntu:~$

History

#1 Updated by Neil Levine about 6 years ago

  • Priority changed from Normal to High

#2 Updated by Alfredo Deza about 6 years ago

  • Assignee set to Anonymous

#3 Updated by Alfredo Deza almost 6 years ago

  • Status changed from New to Closed

This is no longer happening and from ceph-deploy v1.3 we no longer depend on pushy

Also available in: Atom PDF