Project

General

Profile

Bug #54471

cephadm pull help doesn't list all the options

Added by Redouane Kachach Elhichou 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

cephadm pull -h doesn't show the available options (--insecure in this case)

[root@ceph-node-0 ~]# cephadm pull -h
usage: cephadm pull [-h]
optional arguments:
  -h, --help  show this help message and exit

History

#1 Updated by Sebastian Wagner 9 months ago

Thing is: cephadm pull --insecure doesn't actually work for users: every run command might pull the container image (i.e. starting a daemon via systemd) an then podman might pull the container image. Like, if you want to advertise cephadm pull --insecure to users, you should make it work properly

#2 Updated by Redouane Kachach Elhichou 9 months ago

Thanks Sebastian. Do you mean that even if the podman pull fails we don't detect this properly?

#3 Updated by Sebastian Wagner 9 months ago

what I mean is:

0. ssh host1
1. cephadm pull --insecure
2. # deploy mon.host1
3. ceph orch daemon stop mon.host1
4. podman image rm ceph/ceph:v16
5. ceph orch daemon start mon.host1  # this fails, as the image cannot be downlaoded here anymore

#4 Updated by Redouane Kachach Elhichou 9 months ago

Thanks for the clarification Sebastian. I'll close this issue since we can't expose this option by now.

#5 Updated by Redouane Kachach Elhichou 9 months ago

  • Status changed from New to Won't Fix

#6 Updated by Redouane Kachach Elhichou 9 months ago

  • Category changed from cephadm (binary) to cephadm

#7 Updated by Redouane Kachach Elhichou 7 months ago

  • Status changed from Won't Fix to Closed

Also available in: Atom PDF