Project

General

Profile

Bug #54459

fs:upgrade fails with "hit max job timeout"

Added by Venky Shankar 9 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

fs:upgrade test upgrades from pacific v16.2.4 upto lastest. When running with a distro kernel, which might not understand `disable_send_metrics=on' causes the MDS to crash since the client might send a metric type that the MDS does not understand. v16.2.5 has the fix in the MDS (commit cab0dc97a59e08aef53ac916f68de1cb06ba1dc6), so we may as well start upgrade from that.


Related issues

Related to CephFS - Bug #54411: mds_upgrade_sequence: "overall HEALTH_WARN 4 failed cephadm daemon(s); 1 filesystem is degraded; insufficient standby MDS daemons available; 33 daemons have recently crashed" during suites/fsstress.sh Resolved

History

#1 Updated by Venky Shankar 9 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 45242

#2 Updated by Xiubo Li 9 months ago

  • Related to Bug #54411: mds_upgrade_sequence: "overall HEALTH_WARN 4 failed cephadm daemon(s); 1 filesystem is degraded; insufficient standby MDS daemons available; 33 daemons have recently crashed" during suites/fsstress.sh added

#3 Updated by Venky Shankar 7 months ago

  • Status changed from Fix Under Review to Rejected

Also available in: Atom PDF