Project

General

Profile

Bug #54111

data pool attached to a file system can be attached to another file system

Added by Milind Changire 10 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
quincy,pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDSMonitor
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

$ ceph osd pool create prod_meta
$ ceph osd pool create prod_data
$ ceph fs new prod prod_meta prod_data
$ ceph osd pool create backup_meta
$ ceph osd pool create backup_data
$ ceph fs new backup backup_meta backup_data
$ ceph fs add_data_pool prod backup_data
$ ceph-fuse -n client.admin --client_fs prod /mnt/prod
$ mkdir -p /mnt/prod/test/d{0,1}
$ sudo setfattr -n ceph.dir.layout.pool -v backup_data /mnt/prod/test/d1
$ ceph fs dump --format=json-pretty

verify the fs dump to see that the backup pool id is listed for both fs

Related issues

Copied to CephFS - Backport #56113: pacific: data pool attached to a file system can be attached to another file system Rejected
Copied to CephFS - Backport #56114: quincy: data pool attached to a file system can be attached to another file system Rejected

History

#1 Updated by Nikhilkumar Shelke 10 months ago

  • Assignee set to Nikhilkumar Shelke

#2 Updated by Patrick Donnelly 10 months ago

  • Status changed from New to Triaged
  • Priority changed from Normal to Urgent
  • Target version set to v18.0.0
  • Source set to Development
  • Backport set to quincy,pacific
  • Component(FS) MDSMonitor added

#3 Updated by Milind Changire 10 months ago

Also, a metadata pool can't be reused as a metadata pool for another file-system since there's a check to ensure that the metadata pool is empty before being attached to a file-system.

However, an in-use metadata pool can be added as a 'data' pool to another file system and can be written to as well!

#4 Updated by Nikhilkumar Shelke 10 months ago

  • Status changed from Triaged to Fix Under Review

#5 Updated by Venky Shankar 6 months ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Backport Bot 6 months ago

  • Copied to Backport #56113: pacific: data pool attached to a file system can be attached to another file system added

#7 Updated by Backport Bot 6 months ago

  • Copied to Backport #56114: quincy: data pool attached to a file system can be attached to another file system added

#8 Updated by Nikhilkumar Shelke 6 months ago

  • Pull request ID set to 44900

#9 Updated by Nikhilkumar Shelke 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF