Project

General

Profile

Bug #54066

mgr/volumes: uid/gid of the clone is incorrect

Added by Venky Shankar 10 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Category:
Administration/Usability
Target version:
% Done:

100%

Source:
Tags:
Backport:
octopus, quincy, pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://pulpito.ceph.com/vshankar-2022-01-27_12:23:50-fs-wip-vshankar-fscrypt-20220121-095846-testing-default-smithi/6643338/

022-01-27T12:58:30.250 INFO:tasks.cephfs_test_runner:test_subvolume_no_upgrade_v1_sanity (tasks.cephfs.test_volumes.TestMisc) ... FAIL
2022-01-27T12:58:30.251 INFO:tasks.cephfs_test_runner:
2022-01-27T12:58:30.251 INFO:tasks.cephfs_test_runner:======================================================================
2022-01-27T12:58:30.251 INFO:tasks.cephfs_test_runner:FAIL: test_subvolume_no_upgrade_v1_sanity (tasks.cephfs.test_volumes.TestMisc)
2022-01-27T12:58:30.252 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2022-01-27T12:58:30.252 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2022-01-27T12:58:30.252 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_deb627556d87622270d2432ff54074989085bcec/qa/tasks/cephfs/test_volumes.py", line 4686, in test_subvolume_no_upgrade_v1_sanity
2022-01-27T12:58:30.252 INFO:tasks.cephfs_test_runner:    self._verify_clone(subvolume, snapshot, clone1, source_version=1)
2022-01-27T12:58:30.253 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_deb627556d87622270d2432ff54074989085bcec/qa/tasks/cephfs/test_volumes.py", line 154, in _verify_clone
2022-01-27T12:58:30.253 INFO:tasks.cephfs_test_runner:    self._verify_clone_attrs(path1, path2)
2022-01-27T12:58:30.253 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_deb627556d87622270d2432ff54074989085bcec/qa/tasks/cephfs/test_volumes.py", line 99, in _verify_clone_attrs
2022-01-27T12:58:30.254 INFO:tasks.cephfs_test_runner:    self.assertEqual(sval, cval)
2022-01-27T12:58:30.254 INFO:tasks.cephfs_test_runner:AssertionError: 1000 != 0

Related issues

Copied to CephFS - Backport #54256: pacific: mgr/volumes: uid/gid of the clone is incorrect Resolved
Copied to CephFS - Backport #54257: quincy: mgr/volumes: uid/gid of the clone is incorrect Resolved
Copied to CephFS - Backport #54420: octopus: mgr/volumes: uid/gid of the clone is incorrect Rejected

History

#2 Updated by Venky Shankar 10 months ago

  • Assignee set to Kotresh Hiremath Ravishankar

#4 Updated by Kotresh Hiremath Ravishankar 10 months ago

  • Subject changed from test_subvolume_no_upgrade_v1_sanity fails with `AssertionError: 1000 != 0` to mgr/volumes: uid/gid of the clone is incorrect

This is the regression caused by commit 18b85c53a (https://tracker.ceph.com/issues/53848)

Modifying the subject accordingly.

#5 Updated by Venky Shankar 10 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 44970

#6 Updated by Venky Shankar 10 months ago

  • Status changed from Fix Under Review to Pending Backport

#7 Updated by Backport Bot 10 months ago

  • Copied to Backport #54256: pacific: mgr/volumes: uid/gid of the clone is incorrect added

#8 Updated by Backport Bot 10 months ago

  • Copied to Backport #54257: quincy: mgr/volumes: uid/gid of the clone is incorrect added

#9 Updated by Kotresh Hiremath Ravishankar 9 months ago

  • Backport changed from quincy, pacific to octopus, quincy, pacific

#10 Updated by Backport Bot 9 months ago

  • Copied to Backport #54420: octopus: mgr/volumes: uid/gid of the clone is incorrect added

#11 Updated by Backport Bot 4 months ago

  • Tags set to backport_processed

#12 Updated by Konstantin Shalygin 2 months ago

  • Status changed from Pending Backport to Resolved

#13 Updated by Konstantin Shalygin 2 months ago

  • % Done changed from 0 to 100
  • Tags deleted (backport_processed)

Also available in: Atom PDF