Project

General

Profile

Bug #53986

mgr/prometheus: The size of the export is not tracked as a metric returned to Prometheus

Added by Paul Cuzner 11 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
prometheus module
Target version:
% Done:

0%

Source:
Tags:
Backport:
quincy pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Testing on large cluster showed that the payload returned to Prometheus was 54MB - but this was able to be determined by the metrics themselves.

I'm proposing that we add a new metric to the mgr/prometheus which provides a export size, so we can track growth and potentially add an alert - since large payloads can cause issues in export/transmit/response/prometheus.

History

#1 Updated by Paul Cuzner 9 months ago

  • Status changed from New to Closed

Also available in: Atom PDF