Project

General

Profile

Bug #53985

mgr/telemetry: down osds result in empty perf report fields

Added by Laura Flores 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
quincy
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If there is a problem extracting data from a particular osd (i.e. an osd is down), some fields in
the telemetry report show up empty. This is because some functions exit early and return empty JSON objects
upon encountering a down osd rather than continuing and collecting whatever data is available.

The fields that are affected by this bug are "osd_perf_histograms", "mempool", and "heap stats".


Related issues

Copied to mgr - Backport #54274: quincy: mgr/telemetry: down osds result in empty perf report fields Resolved

History

#2 Updated by Konstantin Shalygin 8 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Backport Bot 8 months ago

  • Copied to Backport #54274: quincy: mgr/telemetry: down osds result in empty perf report fields added

#4 Updated by Laura Flores 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF