Project

General

Profile

Actions

Bug #53530

closed

centos’s cephadm shebang does not work on ubuntu

Added by Sebastian Wagner over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

root@storage-01-08002:/var/lib/ceph/f148c330-47c9-11ec-9f19-1dfe2cdc6a6d# ./cephadm.4fd955d0dbf0cdd56104823ef3e950293acaef76608980c02d37021d4c51ee67 
-bash: ./cephadm.4fd955d0dbf0cdd56104823ef3e950293acaef76608980c02d37021d4c51ee67: /usr/libexec/platform-python: bad interpreter: No such file or directory
Actions #1

Updated by Redouane Kachach Elhichou about 2 years ago

Please, can you provide more info on how to reproduce this BUG.

Actions #2

Updated by Redouane Kachach Elhichou about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Redouane Kachach Elhichou
Actions #3

Updated by Redouane Kachach Elhichou about 2 years ago

As of the preliminary investigation it seems the path /usr/libexec/platform-python is used only by RHEL and it points to the Python used by the system. In other distributions (not based on RHEL) this file doesn't exist.

Actions #4

Updated by Redouane Kachach Elhichou about 2 years ago

  • Status changed from In Progress to Rejected

I'm closing this issue because it doesn't describe a real problem that a user may face on practice. It refers to the cephadm binary generated on the cluster and normally used by the mgr. Normal users have to download a valid cephadm (compatible with the cluster) or install it via RPM package.

Actions #5

Updated by Redouane Kachach Elhichou almost 2 years ago

  • Status changed from Rejected to Closed
Actions

Also available in: Atom PDF