Project

General

Profile

Actions

Bug #53365

closed

pacific: broken groups or modules: container-tools:3.0

Added by Kamoltat (Junior) Sirivadhna over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
cephadm
Backport:
Regression:
No
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Seems like in the rados/cephadm/mgr-nfs-upgrade tests, we seem to encounter an error regarding container-tools:3.0.

2021-11-20T16:12:18.937 INFO:teuthology.orchestra.run.smithi136.stderr:No default profiles for module container-tools:3.0. Available profiles: common
2021-11-20T16:12:18.963 INFO:teuthology.orchestra.run.smithi136.stderr:Error: Problems in request:
2021-11-20T16:12:18.963 INFO:teuthology.orchestra.run.smithi136.stderr:broken groups or modules: container-tools:3.0
2021-11-20T16:12:18.972 INFO:teuthology.orchestra.run.smithi142.stderr:No default profiles for module container-tools:3.0. Available profiles: common
2021-11-20T16:12:18.995 DEBUG:teuthology.orchestra.run:got remote process result: 1
2021-11-20T16:12:18.997 ERROR:teuthology.run_tasks:Saw exception from tasks.

Seen in http://pulpito.front.sepia.ceph.com/yuriw-2021-11-20_15:40:33-rados-wip-yuri2-testing-2021-11-19-1714-pacific-distro-basic-smithi/6516164/
as well 6516167, 6516167, 6516171, 6516173, 6516177, 6516180.

Actions #1

Updated by Kamoltat (Junior) Sirivadhna over 2 years ago

  • Assignee set to Sebastian Wagner
Actions #2

Updated by Brad Hubbard over 2 years ago

This is, of course, happening post https://github.com/ceph/ceph/pull/43934 but it's not clear where the actual issue is introduced since running these commands on a freshly provisioned node produces no errors.

Secondly, if I run a job interactively until it fails I can immediately log into the machine shortly after and successfully run the failed command. I'm testing whether a dnf metadata update prior to running the command might help. I suspect it's something similar as it goes away, seemingly by itself, after some delay. Happy to keep looking at this for now Sebastian but by all means let me know if you have any additional thoughts.

Actions #3

Updated by Sebastian Wagner over 2 years ago

  • Project changed from Ceph to Orchestrator
Actions #5

Updated by Sebastian Wagner over 2 years ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 44200
Actions #6

Updated by Sebastian Wagner over 2 years ago

  • Pull request ID changed from 44200 to 44201
Actions #8

Updated by Brad Hubbard over 2 years ago

  • Status changed from Fix Under Review to Resolved
  • Assignee changed from Sebastian Wagner to Yehuda Sadeh
  • Severity deleted (3 - minor)
Actions

Also available in: Atom PDF