Project

General

Profile

Bug #53325

Test failures in ceph_test_cls_rgw_gc

Added by Adam Emerson about 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
% Done:

100%

Source:
Development
Tags:
Backport:
pacific,octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

It looks like this test was left out of teuthology by mistake and something broke somewhere along the line:

On a vstart cluster of one mmonitor and one OSD:

./bin/ceph_test_cls_rgw_gc
Running main() from gmock_main.cc
[==========] Running 11 tests from 1 test suite.
[----------] Global test environment set-up.
[----------] 11 tests from cls_rgw_gc
[ RUN      ] cls_rgw_gc.init
[       OK ] cls_rgw_gc.init (1097 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops1
[          ] list info tag = chain-0
[       OK ] cls_rgw_gc.gc_queue_ops1 (85 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops2
[          ] next_marker is: = 0/4263
[       OK ] cls_rgw_gc.gc_queue_ops2 (40 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops3
/home/azure/work/ceph/repo/src/test/cls_rgw_gc/test_cls_rgw_gc.cc:264: Failure
Expected equality of these values:
  2
  list_info1.size()
    Which is: 1
[  FAILED  ] cls_rgw_gc.gc_queue_ops3 (58 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops4
/home/azure/work/ceph/repo/src/test/cls_rgw_gc/test_cls_rgw_gc.cc:343: Failure
Expected equality of these values:
  2
  list_info1.size()
    Which is: 1
[  FAILED  ] cls_rgw_gc.gc_queue_ops4 (58 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops5
[       OK ] cls_rgw_gc.gc_queue_ops5 (61 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops6
[       OK ] cls_rgw_gc.gc_queue_ops6 (54 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops7
[       OK ] cls_rgw_gc.gc_queue_ops7 (50 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops8
[       OK ] cls_rgw_gc.gc_queue_ops8 (57 ms)
[ RUN      ] cls_rgw_gc.gc_queue_ops9
[       OK ] cls_rgw_gc.gc_queue_ops9 (60 ms)
[ RUN      ] cls_rgw_gc.finalize
[       OK ] cls_rgw_gc.finalize (514 ms)
[----------] 11 tests from cls_rgw_gc (2134 ms total)

[----------] Global test environment tear-down
[==========] 11 tests from 1 test suite ran. (2134 ms total)
[  PASSED  ] 9 tests.
[  FAILED  ] 2 tests, listed below:
[  FAILED  ] cls_rgw_gc.gc_queue_ops3
[  FAILED  ] cls_rgw_gc.gc_queue_ops4

 2 FAILED TESTS

This also reproduces on Pacific and Octopus.


Related issues

Copied to rgw - Backport #53637: pacific: Test failures in ceph_test_cls_rgw_gc Resolved
Copied to rgw - Backport #53638: octopus: Test failures in ceph_test_cls_rgw_gc Rejected

History

#1 Updated by Pritha Srivastava about 1 year ago

The test fails because of code that was commented out from defer gc (related to a data loss bug last year). This test case should ideally be commented out as well, till we have defer gc fixed and enabled.

#2 Updated by Casey Bodley about 1 year ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 44262

#3 Updated by Casey Bodley about 1 year ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot about 1 year ago

  • Copied to Backport #53637: pacific: Test failures in ceph_test_cls_rgw_gc added

#5 Updated by Backport Bot about 1 year ago

  • Copied to Backport #53638: octopus: Test failures in ceph_test_cls_rgw_gc added

#6 Updated by Backport Bot 6 months ago

  • Tags set to backport_processed

#7 Updated by Konstantin Shalygin 4 months ago

  • Status changed from Pending Backport to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (backport_processed)

Also available in: Atom PDF