Project

General

Profile

Bug #53261

pacific: OMAP upgrade to PER-PG format result in skipped first key.

Added by Adam Kupczyk about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This is a regression introduced by fix to omap upgrade: https://github.com/ceph/ceph/pull/43687
The problem is that we always skipped first omap entry.
This works fine with objects having omap header key.
For objects without header key we skipped first actual omap key.


Related issues

Copied from bluestore - Bug #53260: OMAP upgrade to PER-PG format result in skipped first key. Resolved

History

#1 Updated by Adam Kupczyk about 1 year ago

  • Copied from Bug #53260: OMAP upgrade to PER-PG format result in skipped first key. added

#2 Updated by Adam Kupczyk about 1 year ago

  • Pull request ID set to 43916

#3 Updated by Igor Fedotov about 1 year ago

  • Status changed from New to Duplicate

Duplicates #53307

Also available in: Atom PDF