Project

General

Profile

Bug #53214

qa: "dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory"

Added by Patrick Donnelly about 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Testing
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
pacific,octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-11-10T15:29:05.190 DEBUG:teuthology.orchestra.run.smithi152:> (cd /home/ubuntu/cephtest/mnt.0 && exec bash -c 'sudo dd if=/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics')
2021-11-10T15:29:05.282 INFO:teuthology.orchestra.run.smithi152.stderr:dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory
2021-11-10T15:29:05.283 INFO:teuthology.orchestra.run.smithi152.stderr:0+0 records in
2021-11-10T15:29:05.283 INFO:teuthology.orchestra.run.smithi152.stderr:0+0 records out
2021-11-10T15:29:05.283 INFO:teuthology.orchestra.run.smithi152.stderr:0 bytes copied, 9.8217e-05 s, 0.0 kB/s
...
2021-11-10T15:29:15.088 INFO:tasks.cephfs_test_runner:test_flush (tasks.cephfs.test_readahead.TestReadahead) ... ERROR
2021-11-10T15:29:15.089 INFO:tasks.cephfs_test_runner:
2021-11-10T15:29:15.089 INFO:tasks.cephfs_test_runner:======================================================================
2021-11-10T15:29:15.089 INFO:tasks.cephfs_test_runner:ERROR: test_flush (tasks.cephfs.test_readahead.TestReadahead)
2021-11-10T15:29:15.090 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2021-11-10T15:29:15.090 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2021-11-10T15:29:15.090 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_944ff3aec61bad509f93d2743d64bd08bdc242d8/qa/tasks/cephfs/test_readahead.py", line 16, in test_flush
2021-11-10T15:29:15.091 INFO:tasks.cephfs_test_runner:    initial_op_read = self.mount_a.get_op_read_count()
2021-11-10T15:29:15.091 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_944ff3aec61bad509f93d2743d64bd08bdc242d8/qa/tasks/cephfs/kernel_mount.py", line 328, in get_op_read_count
2021-11-10T15:29:15.091 INFO:tasks.cephfs_test_runner:    buf = self.read_debug_file("metrics")
2021-11-10T15:29:15.091 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_944ff3aec61bad509f93d2743d64bd08bdc242d8/qa/tasks/cephfs/kernel_mount.py", line 192, in read_debug_file
2021-11-10T15:29:15.092 INFO:tasks.cephfs_test_runner:    stdout=stdout, stderr=stderr)
2021-11-10T15:29:15.092 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_944ff3aec61bad509f93d2743d64bd08bdc242d8/qa/tasks/cephfs/mount.py", line 712, in run_shell_payload
2021-11-10T15:29:15.092 INFO:tasks.cephfs_test_runner:    return self.run_shell(["bash", "-c", Raw(f"'{payload}'")], **kwargs)
2021-11-10T15:29:15.093 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_944ff3aec61bad509f93d2743d64bd08bdc242d8/qa/tasks/cephfs/mount.py", line 709, in run_shell
2021-11-10T15:29:15.093 INFO:tasks.cephfs_test_runner:    return self.client_remote.run(args=args, cwd=cwd, timeout=timeout, stdout=stdout, stderr=stderr, **kwargs)
2021-11-10T15:29:15.093 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_27954452159076fda5642b6c0eb0c4998b99d2e4/teuthology/orchestra/remote.py", line 509, in run
2021-11-10T15:29:15.093 INFO:tasks.cephfs_test_runner:    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
2021-11-10T15:29:15.094 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_27954452159076fda5642b6c0eb0c4998b99d2e4/teuthology/orchestra/run.py", line 455, in run
2021-11-10T15:29:15.094 INFO:tasks.cephfs_test_runner:    r.wait()
2021-11-10T15:29:15.094 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_27954452159076fda5642b6c0eb0c4998b99d2e4/teuthology/orchestra/run.py", line 161, in wait
2021-11-10T15:29:15.095 INFO:tasks.cephfs_test_runner:    self._raise_for_status()
2021-11-10T15:29:15.095 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_27954452159076fda5642b6c0eb0c4998b99d2e4/teuthology/orchestra/run.py", line 183, in _raise_for_status
2021-11-10T15:29:15.095 INFO:tasks.cephfs_test_runner:    node=self.hostname, label=self.label
2021-11-10T15:29:15.095 INFO:tasks.cephfs_test_runner:teuthology.exceptions.CommandFailedError: Command failed on smithi152 with status 1: "(cd /home/ubuntu/cephtest/mnt.0 && exec bash -c 'sudo dd if=/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics')" 
2021-11-10T15:29:15.096 INFO:tasks.cephfs_test_runner:

From: /ceph/teuthology-archive/pdonnell-2021-11-10_14:59:40-fs-wip-pdonnell-testing-20211109.180315-distro-basic-smithi/6496367/teuthology.log


Related issues

Copied to CephFS - Backport #53443: pacific: qa: "dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory" New
Copied to CephFS - Backport #53444: octopus: qa: "dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory" Resolved

History

#1 Updated by Jeff Layton about 1 year ago

Ahh, that's because it is a directory now, since this patch:

https://lore.kernel.org/ceph-devel/19b30242-15ed-876c-02cb-7d0e2d18ad8d@redhat.com/T/#m26623538becab9f9ed787dabbc4da97a0d936286

I suspect this means we need to alter that test.

#2 Updated by Jeff Layton about 1 year ago

  • Pull request ID set to 43878

#3 Updated by Jeff Layton about 1 year ago

  • Status changed from New to Fix Under Review

#4 Updated by Venky Shankar about 1 year ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Backport Bot about 1 year ago

  • Copied to Backport #53443: pacific: qa: "dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory" added

#6 Updated by Backport Bot about 1 year ago

  • Copied to Backport #53444: octopus: qa: "dd: error reading '/sys/kernel/debug/ceph/2a934501-6731-4052-a836-f42229a869be.client4874/metrics': Is a directory" added

#7 Updated by Cory Snyder about 1 year ago

This patch doesn't appear to be applicable to Pacific or Octopus since the get_op_read_count method doesn't exist in those releases. Can we close the associated backport trackers?

#8 Updated by Jeff Layton about 1 year ago

Yes. Please do close them out. No need to backport this to those.

#9 Updated by Jeff Layton 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF