Project

General

Profile

Bug #53039

osd: ceph osd stop does not take effect

Added by changzhi tan about 1 year ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

100%

Source:
Community (user)
Tags:
Backport:
octopus pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When the cluster network is abnormal, the execution of "ceph osd stop osd.id" will not take effect, and the osd process will still exist

[root@controller-2 ~]# ceph osd tree
ID CLASS WEIGHT TYPE NAME STATUS REWEIGHT PRI-AFF
-2 247.61829 root hdd-DataCenter
-3 61.90457 rack hdd-rack1-DataCenter
-4 61.90457 host hdd-controller-1-rack1-DataCenter
0 hdd 5.15872 osd.0 up 1.00000 1.00000
1 hdd 5.15871 osd.1 up 1.00000 1.00000
2 hdd 5.15872 osd.2 up 1.00000 1.00000
3 hdd 5.15871 osd.3 up 1.00000 1.00000
4 hdd 5.15872 osd.4 up 1.00000 1.00000
5 hdd 5.15871 osd.5 up 1.00000 1.00000
6 hdd 5.15872 osd.6 up 1.00000 1.00000
7 hdd 5.15871 osd.7 up 1.00000 1.00000
8 hdd 5.15872 osd.8 up 1.00000 1.00000
9 hdd 5.15871 osd.9 up 1.00000 1.00000
10 hdd 5.15872 osd.10 up 1.00000 1.00000
11 hdd 5.15871 osd.11 up 1.00000 1.00000
-7 61.90457 rack hdd-rack2-DataCenter
-8 61.90457 host hdd-controller-2-rack2-DataCenter
12 hdd 5.15872 osd.12 down 1.00000 1.00000
13 hdd 5.15871 osd.13 down 1.00000 1.00000
14 hdd 5.15872 osd.14 down 1.00000 1.00000
15 hdd 5.15871 osd.15 down 1.00000 1.00000
16 hdd 5.15872 osd.16 down 1.00000 1.00000
17 hdd 5.15871 osd.17 down 1.00000 1.00000
18 hdd 5.15872 osd.18 down 1.00000 1.00000
19 hdd 5.15871 osd.19 down 1.00000 1.00000
20 hdd 5.15872 osd.20 down 1.00000 1.00000
21 hdd 5.15871 osd.21 down 1.00000 1.00000
22 hdd 5.15872 osd.22 down 1.00000 1.00000
23 hdd 5.15871 osd.23 down 1.00000 1.00000
-5 61.90457 rack hdd-rack3-DataCenter
-6 61.90457 host hdd-controller-3-rack3-DataCenter
24 hdd 5.15872 osd.24 up 1.00000 1.00000
25 hdd 5.15871 osd.25 up 1.00000 1.00000
26 hdd 5.15872 osd.26 up 1.00000 1.00000
27 hdd 5.15871 osd.27 up 1.00000 1.00000
28 hdd 5.15872 osd.28 up 1.00000 1.00000
29 hdd 5.15871 osd.29 up 1.00000 1.00000
30 hdd 5.15872 osd.30 up 1.00000 1.00000
31 hdd 5.15871 osd.31 up 1.00000 1.00000
32 hdd 5.15872 osd.32 up 1.00000 1.00000
33 hdd 5.15871 osd.33 up 1.00000 1.00000
34 hdd 5.15872 osd.34 up 1.00000 1.00000
35 hdd 5.15871 osd.35 up 1.00000 1.00000
-9 61.90457 rack hdd-rack4-DataCenter
-10 61.90457 host hdd-controller-4-rack4-DataCenter
36 hdd 5.15872 osd.36 up 1.00000 1.00000
37 hdd 5.15871 osd.37 up 1.00000 1.00000
38 hdd 5.15872 osd.38 up 1.00000 1.00000
39 hdd 5.15871 osd.39 up 1.00000 1.00000
40 hdd 5.15872 osd.40 up 1.00000 1.00000
41 hdd 5.15871 osd.41 up 1.00000 1.00000
42 hdd 5.15872 osd.42 up 1.00000 1.00000
43 hdd 5.15871 osd.43 up 1.00000 1.00000
44 hdd 5.15872 osd.44 up 1.00000 1.00000
45 hdd 5.15871 osd.45 up 1.00000 1.00000
46 hdd 5.15872 osd.46 up 1.00000 1.00000
47 hdd 5.15871 osd.47 up 1.00000 1.00000

[root@controller-2 ~]# ceph osd stop osd.12
stop down osd.12.

This is because osd is in the waiting_for_healthy state, which prevents do_shutdown from being false, so osd.12 will not receive SIGINT


Related issues

Copied to mgr - Backport #53200: octopus: osd: ceph osd stop does not take effect Resolved
Copied to mgr - Backport #53201: pacific: osd: ceph osd stop does not take effect Resolved

History

#2 Updated by Yuri Weinstein about 1 year ago

changzhi tan wrote:

https://github.com/ceph/ceph/pull/43664

merged

#3 Updated by changzhi tan about 1 year ago

backport v15.2.16

#4 Updated by Konstantin Shalygin about 1 year ago

  • Status changed from New to Pending Backport
  • Assignee set to changzhi tan
  • Target version changed from v15.2.16 to v17.0.0
  • Source set to Community (user)
  • Backport set to octopus pacific
  • Pull request ID set to 43664

#5 Updated by Konstantin Shalygin about 1 year ago

  • Copied to Backport #53200: octopus: osd: ceph osd stop does not take effect added

#6 Updated by Backport Bot about 1 year ago

  • Copied to Backport #53201: pacific: osd: ceph osd stop does not take effect added

#7 Updated by Konstantin Shalygin about 1 year ago

  • Copied to Bug #53202: pacific: osd: ceph osd stop does not take effect added

#8 Updated by Konstantin Shalygin about 1 year ago

  • Copied to deleted (Bug #53202: pacific: osd: ceph osd stop does not take effect)

#9 Updated by Backport Bot 4 months ago

  • Tags set to backport_processed

#10 Updated by Konstantin Shalygin 2 months ago

  • Status changed from Pending Backport to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (backport_processed)

Also available in: Atom PDF