Project

General

Profile

Bug #53024

mgr/dashboard: make check failure because of conflicting versions

Added by Nizamudeen A 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Build, CI, Dependencies & Tools
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

INFO: pip is looking at multiple versions of defusedxml to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of python3-saml to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of isort to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of rstcheck to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of flake8-colors to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of flake8 to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of <Python from Requires-Python> to determine which version is compatible with other requirements. This could take a while.
INFO: pip is looking at multiple versions of pylint to determine which version is compatible with other requirements. This could take a while.
ERROR: Cannot install -r requirements-lint.txt (line 2) and -r requirements-lint.txt (line 8) because these package versions have conflicting dependencies.

The conflict is caused by:
    flake8 3.9.0 depends on pycodestyle<2.8.0 and >=2.7.0
    autopep8 1.6.0 depends on pycodestyle>=2.8.0

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies

Related issues

Copied to Dashboard - Backport #53026: pacific: mgr/dashboard: make check failure because of conflicting versions Resolved

History

#1 Updated by Nizamudeen A 3 months ago

  • Description updated (diff)

#2 Updated by Nizamudeen A 3 months ago

  • Backport set to pacific

#3 Updated by Nizamudeen A 3 months ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot 3 months ago

  • Copied to Backport #53026: pacific: mgr/dashboard: make check failure because of conflicting versions added

#5 Updated by Nizamudeen A 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF