Project

General

Profile

Bug #52622

nautilus build fails on centos stream 8

Added by Dan van der Ster over 1 year ago. Updated over 1 year ago.

Status:
Won't Fix
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Our nautilus builds on stream 8 started failing recently. Is it because Stream 8 recently moved to nspr 4.32 ?
We haven't tried octopus or pacific yet, but maybe this was already fixed there.

-- Checking for module 'nspr'
--   Found nspr, version 4.32.0
-- Found NSPR: /usr/lib64/libplds4.so;/usr/lib64/libplc4.so;/usr/lib64/libnspr4.so  
...
/usr/include/nspr4/prlog.h:217:27: error: expected unqualified-id before 'void'
 #define PR_ASSERT(expr) ((void) 0)
                           ^~~~
...

Here's the build log: https://pastebin.com/raw/KrASdks1

History

#1 Updated by Dan van der Ster over 1 year ago

  • Status changed from New to Won't Fix
  • Assignee set to Dan van der Ster

octopus builds just fine on Stream 8 as of today.

We found that this PR is missing from nautilus: https://github.com/ceph/ceph/pull/27834
It's too complex/risky to backport to nautilus so we'll just move our clients ahead to octopus.

Closing.

Also available in: Atom PDF