Project

General

Profile

Feature #526

osd: unfound objects rework

Added by Colin McCabe almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

We want to let the page group go active even if there are some unfound objects. We will keep track of which objects are unfound. Hopefully a stray OSD that comes up later will tell us where they are.

When a client tries to read from those unfound objects, it should block. (This part should already be implemented?)


Related issues

Related to Ceph - Bug #428: osd: recovery stalls on mismatched snapset and object Resolved 09/23/2010
Related to Ceph - Bug #491: osd: pg incorrectly going active Can't reproduce 10/14/2010
Related to Ceph - Bug #492: osd: do not remove divergent objects Rejected 10/14/2010
Related to Ceph - Feature #453: osd: return error (instead of blocking) on lost objects Resolved 10/19/2010 10/19/2010
Related to Ceph - Bug #503: osd: query osds since last_epoch_clean before concluding objects lost? Closed 10/18/2010

History

#1 Updated by Sage Weil almost 10 years ago

  • Target version set to v0.24

#2 Updated by Sage Weil almost 10 years ago

  • Estimated time set to 4.00 h
  • Source set to 5

#3 Updated by Colin McCabe almost 10 years ago

  • Status changed from New to Resolved

We now let the PG become active even when there are unfound objects. When the user tries to read one of those objects, he has to block until we find it.

So this one is done.

Also available in: Atom PDF