Project

General

Profile

Bug #52279

cephadm tests fail due to: error adding seccomp filter rule for syscall bdflush: requested action matches default action of filter

Added by Kefu Chai over 1 year ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-08-16T02:38:47.473 INFO:teuthology.orchestra.run.smithi170.stderr:Running command: /bin/podman run --rm --ipc=host --stop-signal=SIGTERM --net=host --entrypoint ceph --init -e CONTAINER_IMAGE=quay.ce
ph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da -e NODE_NAME=smithi170 -e CEPH_USE_RANDOM_NONCE=1 quay.ceph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da --version
2021-08-16T02:38:59.955 INFO:teuthology.orchestra.run.smithi170.stderr:ceph: Error: OCI runtime error: container_linux.go:380: starting container process caused: error adding seccomp filter rule for syscall bdflush: requested action matches default action of filter
2021-08-16T02:38:59.957 INFO:teuthology.orchestra.run.smithi170.stderr:Non-zero exit code 126 from /bin/podman run --rm --ipc=host --stop-signal=SIGTERM --net=host --entrypoint ceph --init -e CONTAINER_IM
AGE=quay.ceph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da -e NODE_NAME=smithi170 -e CEPH_USE_RANDOM_NONCE=1 quay.ceph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da --version
2021-08-16T02:38:59.958 INFO:teuthology.orchestra.run.smithi170.stderr:ceph: stderr Error: OCI runtime error: container_linux.go:380: starting container process caused: error adding seccomp filter rule fo
r syscall bdflush: requested action matches default action of filter
2021-08-16T02:38:59.962 INFO:teuthology.orchestra.run.smithi170.stderr:Traceback (most recent call last):
2021-08-16T02:38:59.963 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 8456, in <module>
2021-08-16T02:38:59.963 INFO:teuthology.orchestra.run.smithi170.stderr:    main()
2021-08-16T02:38:59.963 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 8444, in main
2021-08-16T02:38:59.963 INFO:teuthology.orchestra.run.smithi170.stderr:    r = ctx.func(ctx)
2021-08-16T02:38:59.964 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1782, in _default_image
2021-08-16T02:38:59.964 INFO:teuthology.orchestra.run.smithi170.stderr:    return func(ctx)
2021-08-16T02:38:59.964 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 4210, in command_bootstrap
2021-08-16T02:38:59.964 INFO:teuthology.orchestra.run.smithi170.stderr:    image_ver = CephContainer(ctx, ctx.image, 'ceph', ['--version']).run().strip()
2021-08-16T02:38:59.965 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 3439, in run
2021-08-16T02:38:59.965 INFO:teuthology.orchestra.run.smithi170.stderr:    desc=self.entrypoint, timeout=timeout)
2021-08-16T02:38:59.965 INFO:teuthology.orchestra.run.smithi170.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1462, in call_throws
2021-08-16T02:38:59.965 INFO:teuthology.orchestra.run.smithi170.stderr:    raise RuntimeError('Failed command: %s' % ' '.join(command))
2021-08-16T02:38:59.966 INFO:teuthology.orchestra.run.smithi170.stderr:RuntimeError: Failed command: /bin/podman run --rm --ipc=host --stop-signal=SIGTERM --net=host --entrypoint ceph --init -e CONTAINER_
IMAGE=quay.ceph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da -e NODE_NAME=smithi170 -e CEPH_USE_RANDOM_NONCE=1 quay.ceph.io/ceph-ci/ceph:f435859ec4ee4b5dc9903c209333ddbd17f7e1da --version
2021-08-16T02:38:59.987 DEBUG:teuthology.orchestra.run:got remote process result: 1

see

History

#1 Updated by Sebastian Wagner over 1 year ago

  • Project changed from CI to Orchestrator

#2 Updated by Sebastian Wagner over 1 year ago

  • Subject changed from cephadm tests fail due to "OCI runtime error" to cephadm tests fail due to: error adding seccomp filter rule fo r syscall bdflush: requested action matches default action of filter

#3 Updated by Kefu Chai over 1 year ago

all on centos 8.2 and centos 8.3

#4 Updated by Kefu Chai over 1 year ago

  • Description updated (diff)

#5 Updated by Sebastian Wagner over 1 year ago

  • Subject changed from cephadm tests fail due to: error adding seccomp filter rule fo r syscall bdflush: requested action matches default action of filter to cephadm tests fail due to: error adding seccomp filter rule for syscall bdflush: requested action matches default action of filter

#7 Updated by Sebastian Wagner over 1 year ago

  • Priority changed from Normal to Urgent

#9 Updated by Yuri Weinstein over 1 year ago

  • Backport set to pacific

#11 Updated by Sebastian Wagner over 1 year ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 42852

#12 Updated by Sebastian Wagner over 1 year ago

  • Status changed from Fix Under Review to Pending Backport

#13 Updated by Sebastian Wagner over 1 year ago

  • Status changed from Pending Backport to Resolved

#14 Updated by Deepika Upadhyay over 1 year ago

  • Backport changed from pacific to pacific, octopus

#15 Updated by Deepika Upadhyay over 1 year ago

  • Status changed from Resolved to Pending Backport

#16 Updated by Sebastian Wagner about 1 year ago

  • Status changed from Pending Backport to Resolved

#18 Updated by Aishwarya Mathuria about 1 year ago

/a/yuriw-2021-11-20_18:01:41-rados-wip-yuri8-testing-2021-11-20-0807-distro-basic-smithi/6516634

#19 Updated by Sebastian Wagner about 1 year ago

  • Priority changed from Urgent to Normal

#21 Updated by Neha Ojha about 1 year ago

Noticed this failure in upgrade tests in octopus

2021-12-01T18:20:43.510 INFO:teuthology.orchestra.run.smithi138.stderr:Extracting ceph user uid/gid from container image...
2021-12-01T18:20:43.510 INFO:teuthology.orchestra.run.smithi138.stderr:Running command: /bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=docker.io/ceph/ceph:v15.2.9 -e NODE_NAME=smithi138 docker.io/ceph/ceph:v15.2.9 -c %u %g /var/lib/ceph
2021-12-01T18:20:44.216 INFO:teuthology.orchestra.run.smithi138.stderr:stat: stderr Error: OCI runtime error: container_linux.go:367: starting container process caused: error adding seccomp filter rule for syscall bdflush: requested action matches default action of filter
2021-12-01T18:20:44.218 INFO:teuthology.orchestra.run.smithi138.stderr:Non-zero exit code 126 from /bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=docker.io/ceph/ceph:v15.2.9 -e NODE_NAME=smithi138 docker.io/ceph/ceph:v15.2.9 -c %u %g /var/lib/ceph
2021-12-01T18:20:44.218 INFO:teuthology.orchestra.run.smithi138.stderr:stat: stderr Error: OCI runtime error: container_linux.go:367: starting container process caused: error adding seccomp filter rule for syscall bdflush: requested action matches default action of filter
2021-12-01T18:20:44.221 INFO:teuthology.orchestra.run.smithi138.stderr:Traceback (most recent call last):
2021-12-01T18:20:44.221 INFO:teuthology.orchestra.run.smithi138.stderr:  File "/home/ubuntu/cephtest/cephadm", line 6151, in <module>
2021-12-01T18:20:44.221 INFO:teuthology.orchestra.run.smithi138.stderr:    r = args.func()
2021-12-01T18:20:44.221 INFO:teuthology.orchestra.run.smithi138.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1410, in _default_image
2021-12-01T18:20:44.222 INFO:teuthology.orchestra.run.smithi138.stderr:    return func()
2021-12-01T18:20:44.222 INFO:teuthology.orchestra.run.smithi138.stderr:  File "/home/ubuntu/cephtest/cephadm", line 2914, in command_bootstrap
2021-12-01T18:20:44.222 INFO:teuthology.orchestra.run.smithi138.stderr:    (uid, gid) = extract_uid_gid()
2021-12-01T18:20:44.222 INFO:teuthology.orchestra.run.smithi138.stderr:  File "/home/ubuntu/cephtest/cephadm", line 2097, in extract_uid_gid
2021-12-01T18:20:44.223 INFO:teuthology.orchestra.run.smithi138.stderr:    raise RuntimeError('uid/gid not found')
2021-12-01T18:20:44.223 INFO:teuthology.orchestra.run.smithi138.stderr:RuntimeError: uid/gid not found
2021-12-01T18:20:44.224 INFO:teuthology.orchestra.run.smithi138.stderr:Releasing lock 139789783885024 on /run/cephadm/5c019de6-52d3-11ec-8c2d-001a4aab830c.lock
2021-12-01T18:20:44.225 INFO:teuthology.orchestra.run.smithi138.stderr:Lock 139789783885024 released on /run/cephadm/5c019de6-52d3-11ec-8c2d-001a4aab830c.lock
2021-12-01T18:20:44.234 DEBUG:teuthology.orchestra.run:got remote process result: 1

rados/cephadm/upgrade/{1-start-distro/1-start-centos_8 2-repo_digest/repo_digest 3-start-upgrade 4-wait fixed-2}

/a/yuriw-2021-12-01_17:25:46-rados-wip-yuri8-testing-2021-11-30-0825-octopus-distro-default-smithi/6538519

#22 Updated by Nitzan Mordechai 5 months ago

/a/yuriw-2022-08-31_18:06:39-rados-wip-yuri7-testing-2022-08-31-0841-distro-default-smithi/7003285

#23 Updated by Redouane Kachach Elhichou 5 months ago

From the error, it could be a podman issue: https://github.com/containers/podman/issues/11883

Also available in: Atom PDF