Project

General

Profile

Actions

Bug #52109

closed

test_cephadm.sh: Timeout('Port 8443 not free on 127.0.0.1.',)

Added by Sebastian Wagner over 2 years ago. Updated 1 day ago.

Status:
Won't Fix
Priority:
High
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://sentry.ceph.com/organizations/ceph/issues/1585/?project=2&query=is%3Aunresolved+%22workunit+test+cephadm%22&statsPeriod=14d

2021-08-08T08:51:36.788 INFO:tasks.workunit.client.0.smithi173.stdout:Aug 08 08:47:54 smithi173 ceph-mgr[45646]: Traceback (most recent call last):
2021-08-08T08:51:36.788 INFO:tasks.workunit.client.0.smithi173.stdout:                                             File "/usr/share/ceph/mgr/dashboard/module.py", line 503, in serve
2021-08-08T08:51:36.789 INFO:tasks.workunit.client.0.smithi173.stdout:                                               cherrypy.engine.start()
2021-08-08T08:51:36.789 INFO:tasks.workunit.client.0.smithi173.stdout:                                             File "/lib/python3.6/site-packages/cherrypy/process/wspbus.py", line 283, in start
2021-08-08T08:51:36.789 INFO:tasks.workunit.client.0.smithi173.stdout:                                               raise e_info
2021-08-08T08:51:36.789 INFO:tasks.workunit.client.0.smithi173.stdout:                                             File "/lib/python3.6/site-packages/cherrypy/process/wspbus.py", line 268, in start
2021-08-08T08:51:36.789 INFO:tasks.workunit.client.0.smithi173.stdout:                                               self.publish('start')
2021-08-08T08:51:36.790 INFO:tasks.workunit.client.0.smithi173.stdout:                                             File "/lib/python3.6/site-packages/cherrypy/process/wspbus.py", line 248, in publish
2021-08-08T08:51:36.790 INFO:tasks.workunit.client.0.smithi173.stdout:                                               raise exc
2021-08-08T08:51:36.790 INFO:tasks.workunit.client.0.smithi173.stdout:                                           cherrypy.process.wspbus.ChannelFailures: Timeout('Port 8443 not free on 127.0.0.1.',)

http://qa-proxy.ceph.com/teuthology/kchai-2021-08-08_08:16:57-rados-wip-kefu-testing-2021-08-08-1031-distro-basic-smithi/6326974/teuthology.log
https://pulpito.ceph.com/sage-2021-08-06_19:04:50-orch-master-distro-basic-smithi/


Related issues 1 (0 open1 closed)

Has duplicate Dashboard - Bug #65129: Unhandled Dashboard exception related to CherryPyDuplicate

Actions
Actions #1

Updated by Sebastian Wagner over 2 years ago

  • Assignee set to Daniel Pivonka
Actions #2

Updated by Daniel Pivonka over 2 years ago

  • Status changed from New to Won't Fix

test_cephadm.sh deploys two mgrs on the same host first one from bootstrap and the second with cephadm deploy. both mgrs will want to bind to 127.0.0.1:8443. the second mgrs dashboard module will fail because the first mgrs dashboard module has already binded to 127.0.0.1:8443. this failure is not a fatal error and will not crash the test but can be seen in the second mgrs logs. it does not effect the test though. closing as this doesn't really effect the test and there is no good solution to stop the error.

https://github.com/ceph/ceph/blob/master/qa/workunits/cephadm/test_cephadm.sh#L241

Actions #3

Updated by Laura Flores 12 months ago

/a/yuriw-2023-04-26_20:20:05-rados-pacific-release-distro-default-smithi/7255305

Actions #4

Updated by Matan Breizman 2 months ago

/a/yuriw-2024-02-09_00:15:46-rados-wip-yuri2-testing-2024-02-08-0727-distro-default-smithi/7553385

Actions #5

Updated by Sridhar Seshasayee about 1 month ago

/a/yuriw-2024-03-08_16:20:46-rados-wip-yuri4-testing-2024-03-05-0854-distro-default-smithi/7587370

Actions #6

Updated by Laura Flores 18 days ago

/a/yuriw-2024-03-24_22:19:24-rados-wip-yuri10-testing-2024-03-24-1159-distro-default-smithi/7620513

Actions #7

Updated by Laura Flores 18 days ago

  • Has duplicate Bug #65129: Unhandled Dashboard exception related to CherryPy added
Actions #8

Updated by Laura Flores 8 days ago

/a/yuriw-2024-04-09_14:58:25-rados-wip-yuri4-testing-2024-04-08-1432-distro-default-smithi/7648958

Actions #9

Updated by Laura Flores 3 days ago

/a/yuriw-2024-04-10_14:17:51-rados-wip-yuri6-testing-2024-04-02-1310-distro-default-smithi/7650646

Actions #10

Updated by Matan Breizman 1 day ago

/a/yuriw-2024-04-16_23:25:35-rados-wip-yuriw-testing-20240416.150233-distro-default-smithi/7659292

Actions

Also available in: Atom PDF