Project

General

Profile

Bug #52064

octopus: cephadm bootstrap --container-init broken in Octopus

Added by Nathan Cutler over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In Octopus, when the user provides the "--container-init" option to "cephadm bootstrap", all containerized daemons in the cluster are supposed to get the "--init" option in their unit.run files, to ensure that an init process runs as PID 1 in the container. (Without this, the containerized daemons fail to generate coredumps when they crash.)

However, due to a bug in Octopus, when the "--container-init" option is provided to "cephadm bootstrap", only the daemons actually created by the bootstrap operation (which in some cases might be just 1 MON and 1 MGR) get the "--init" in their unit.run. Daemons created post-bootstrap using "ceph orch apply" do not get the "--init" goodness, giving rise to an undesirable situation where 1 MON and 1 MGR generate coredumps when they crash, but all other daemons in the cluster fail to do so.

Since "--container-init" is already deprecated in Octopus, I'm not sure if newer versions of Ceph (pacific, quincy, etc.) suffer from this bug.

History

#1 Updated by Tim Serong over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Tim Serong
  • Pull request ID set to 42666

#2 Updated by Tim Serong over 1 year ago

  • Status changed from In Progress to Fix Under Review

#4 Updated by Nathan Cutler over 1 year ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF