Project

General

Profile

Bug #51713

Cephadm: Timeout waiting for ingress.nfs.foo to start

Added by Sridhar Seshasayee 2 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Test Description:
rados/cephadm/smoke-roleless/{0-distro/ubuntu_20.04 1-start 2-services/nfs-ingress2 3-final}

Logs:
/a/sseshasa-2021-07-14_10:37:09-rados-wip-sseshasa-testing-2021-07-14-1320-distro-basic-smithi/6269984
/a/sseshasa-2021-07-16_13:48:47-rados-wip-sseshasa-testing-2021-07-16-1632-distro-basic-smithi/6275977

Traceback:

2021-07-14T11:54:35.440 INFO:tasks.cephadm:ingress.nfs.foo has 0/4
2021-07-14T11:54:35.440 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_22d0fca188262bb2f460f46cb79ab21e54fb316f/teuthology/run_tasks.py", line 91, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_22d0fca188262bb2f460f46cb79ab21e54fb316f/teuthology/run_tasks.py", line 70, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/git.ceph.com_ceph-c_f81345ca72228f2b22752a42ef3d4cfb048530bb/qa/tasks/cephadm.py", line 1093, in wait_for_service
    while proceed():
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_22d0fca188262bb2f460f46cb79ab21e54fb316f/teuthology/contextutil.py", line 133, in __call__
    raise MaxWhileTries(error_msg)
teuthology.exceptions.MaxWhileTries: reached maximum tries (300) after waiting for 300 seconds


Related issues

Duplicates Orchestrator - Bug #51311: Failed to apply ingress.rgw: IndexError: list index out of range Resolved

History

#1 Updated by Sebastian Wagner 2 months ago

h[12603]: Traceback (most recent call last):
h[12603]:   File "/usr/share/ceph/mgr/cephadm/serve.py", line 588, in _apply_all_services
h[12603]:     if self._apply_service(spec):
h[12603]:   File "/usr/share/ceph/mgr/cephadm/serve.py", line 811, in _apply_service
h[12603]:     daemon_spec = svc.prepare_create(daemon_spec)
h[12603]:   File "/usr/share/ceph/mgr/cephadm/services/ingress.py", line 31, in prepare_create
h[12603]:     return self.keepalived_prepare_create(daemon_spec)
h[12603]:   File "/usr/share/ceph/mgr/cephadm/services/ingress.py", line 161, in keepalived_prepare_create
h[12603]:     daemon_spec.final_config, daemon_spec.deps = self.keepalived_generate_config(daemon_spec)
h[12603]:   File "/usr/share/ceph/mgr/cephadm/services/ingress.py", line 228, in keepalived_generate_config
h[12603]:     if hosts[0] == host:
h[12603]: IndexError: list index out of range

Also found in https://github.com/ceph/ceph/pull/42389

#2 Updated by Neha Ojha 2 months ago

  • Priority changed from Normal to High

Seems to be failing consistently

rados/cephadm/smoke-roleless/{0-distro/ubuntu_20.04 1-start 2-services/nfs-ingress2 3-final}

/a/yuriw-2021-07-17_14:59:42-rados-wip-yuri-testing-master-7.16.21-distro-basic-smithi/6277692

#3 Updated by Sebastian Wagner 2 months ago

  • Duplicates Bug #51311: Failed to apply ingress.rgw: IndexError: list index out of range added

#4 Updated by Sebastian Wagner 2 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF