Project

General

Profile

Bug #51672

mgr/dashboard: test_dashboard_e2e.sh: "AssertionError: Timed out retrying: Expected to find content: 'Continue' within the selector: 'cd-modal button' but never did."

Added by Ernesto Puerta 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Component - Orchestrator
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
pacific
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In https://pulpito.ceph.com/yuriw-2021-07-13_15:17:07-rados-wip-yuri2-testing-2021-07-08-1142-pacific-distro-basic-smithi/:
      1) should force enter host into maintenance

  0 passing (2m)
  1 failing

  1) Hosts page
       when Orchestrator is available
         should force enter host into maintenance:
     AssertionError: Timed out retrying: Expected to find content: 'Continue' within the selector: 'cd-modal button' but never did.
      at HostsPageHelper.maintenance (https://172.21.15.100:8443/__cypress/tests?p=cypress/integration/orchestrator/01-hosts-force-maintenance.e2e-spec.ts:218:16)
      at HostsPageHelper.descriptor.value (https://172.21.15.100:8443/__cypress/tests?p=cypress/integration/orchestrator/01-hosts-force-maintenance.e2e-spec.ts:370:20)
      at Context.eval (https://172.21.15.100:8443/__cypress/tests?p=cypress/integration/orchestrator/01-hosts-force-maintenance.e2e-spec.ts:337:23)

Related issues

Duplicates Dashboard - Bug #50771: mgr/dashboard: test_error force maintenance dashboard check Resolved

History

#1 Updated by Ernesto Puerta 3 months ago

  • Status changed from New to Need More Info

#2 Updated by Nizamudeen A 3 months ago

  • Status changed from Need More Info to Duplicate

This is the duplicate of one Sage reported to us in the IRC https://tracker.ceph.com/issues/50771. I created a tracker for this at that time. We also have a fix open for it. So let's see if it can get merged sooner.

#3 Updated by Ernesto Puerta 2 months ago

  • Duplicates Bug #50771: mgr/dashboard: test_error force maintenance dashboard check added

Also available in: Atom PDF