Project

General

Profile

Bug #51661

Manual datalog trim segfaaults

Added by Adam Emerson over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If the target generation is the last, falls off the end of the map and tries to derefrence the past-the-end iterator.

Slipped through the testing since multisite tests always use the AioCompletion version.


Related issues

Copied to rgw - Backport #51675: pacific: Manual datalog trim segfaaults Resolved

History

#1 Updated by Adam Emerson over 1 year ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Casey Bodley over 1 year ago

  • Pull request ID set to 42324

#3 Updated by Adam Emerson over 1 year ago

  • Status changed from Fix Under Review to Pending Backport
  • Assignee set to Adam Emerson

#4 Updated by Backport Bot over 1 year ago

#5 Updated by Loïc Dachary over 1 year ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF