Project

General

Profile

Actions

Bug #51611

closed

Directories Menu Can't Use on Ceph File System Dashboard

Added by Prince Inamatus almost 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Component - CephFS
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
pacific
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

After upgrade to 16.2.5 This error is appear. When I use on 16.2.3 this error didn't appear.

2021-07-09T21:13:51.924+0700 7f2b98711700 0 [dashboard ERROR exception] Internal Server Error
Traceback (most recent call last):
File "/usr/share/ceph/mgr/dashboard/services/exception.py", line 46, in dashboard_exception_handler
return handler(*args, **kwargs)
File "/usr/lib/python3/dist-packages/cherrypy/_cpdispatch.py", line 60, in call
return self.callable(*self.args, **self.kwargs)
File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 694, in inner
ret = func(*args, **kwargs)
File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 909, in wrapper
return func(*vpath, **params)
File "/usr/share/ceph/mgr/dashboard/controllers/cephfs.py", line 540, in ls_dir
paths = cfs.ls_dir(path, depth)
File "/usr/share/ceph/mgr/dashboard/services/cephfs.py", line 77, in ls_dir
return [self.get_directory(p) for p in paths if p != path.encode()]
File "/usr/share/ceph/mgr/dashboard/services/cephfs.py", line 77, in <listcomp>
return [self.get_directory(p) for p in paths if p != path.encode()]
File "/usr/share/ceph/mgr/dashboard/services/cephfs.py", line 129, in get_directory
'snapshots': self.ls_snapshots(path),
File "/usr/share/ceph/mgr/dashboard/services/cephfs.py", line 201, in ls_snapshots
with self.opendir(path) as d:
File "/usr/lib/python3.6/contextlib.py", line 81, in enter
return next(self.gen)
File "/usr/share/ceph/mgr/dashboard/services/cephfs.py", line 57, in opendir
d = self.cfs.opendir(dirpath)
File "cephfs.pyx", line 942, in cephfs.LibCephFS.opendir
cephfs.OSError: opendir failed: Permission denied [Errno 13]
2021-07-09T21:13:51.928+0700 7f2b98711700 0 [dashboard ERROR request] [10.0.80.2:53485] [GET] [500] [0.083s] [admin] [513.0B] /ui-api/cephfs/1/ls_dir
2021-07-09T21:13:51.928+0700 7f2b98711700 0 [dashboard ERROR request] [b'{"status": "500 Internal Server Error", "detail": "The server encountered an unexpected condition which prevented it from fulfilling the request.", "request_id": "d0b14426-eeab-41d1-824a-7ea347207e5d"}


Related issues 1 (0 open1 closed)

Copied to Dashboard - Backport #54269: pacific: Directories Menu Can't Use on Ceph File System DashboardResolvedSarthak GuptaActions
Actions #1

Updated by Ernesto Puerta over 2 years ago

  • Status changed from New to Triaged
  • Assignee set to Waad Alkhoury
  • Target version set to v16.2.6
  • Source set to Community (user)
  • Backport set to pacific
  • Regression changed from No to Yes
Actions #2

Updated by Loïc Dachary over 2 years ago

  • Target version deleted (v16.2.6)
Actions #3

Updated by Ernesto Puerta about 2 years ago

User E Taka that reported the same problem in the ceph-users mailing list added steps for reproducing it and resolution:

I found the reason. One of the users set a directory permission without the
+x bit (drw-------). After the command 'chmod 700' everything was OK again.
The MDS log did not help, but with the API call 'ls_dir?path=…' I was able
to iterate to the directory with the wrong permissions.

IMHO this is not an urgent problem , but an user should not be able to
crash the management interface of the admin.

So a solution would be to handle these exceptions in the Dashboard cephfs logic (libcephfs exception) and return a red pop up notification.

Actions #4

Updated by Sarthak Gupta about 2 years ago

  • Assignee changed from Waad Alkhoury to Sarthak Gupta
Actions #5

Updated by Ernesto Puerta about 2 years ago

  • Pull request ID set to 44849
Actions #6

Updated by Ernesto Puerta about 2 years ago

  • Status changed from Triaged to In Progress
Actions #7

Updated by Sarthak Gupta about 2 years ago

  • Status changed from In Progress to Resolved
Actions #8

Updated by Nizamudeen A about 2 years ago

  • Status changed from Resolved to Pending Backport

Hey Sarthak, you need to do the pacific backport too before marking it as Resolved. So if there is any Pending Backport to be done, we change the status to Pending Backport and do the backport. Once it is done we move it to Resolved

Actions #9

Updated by Backport Bot about 2 years ago

  • Copied to Backport #54269: pacific: Directories Menu Can't Use on Ceph File System Dashboard added
Actions #10

Updated by Ernesto Puerta about 2 years ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF