Project

General

Profile

Bug #51426

ceph orch stop should not remove systemctl entries

Added by Vikhyat Umrao 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

1. For example if we run `ceph orch stop mgr` the command stops all the mgr services.
2. Once `ceph orch` stops the mgr pods it also removes mgr services entries from systemctl this can be verified via `systemctl -l | grep mgr`

Expected results should be the systemctl unit entries should not be removed when we stop daemons via `ceph orch stop` command.

Stopping mgr and mon services makes orch commands not work and then you login to mgr or/and mon to start the process and you do not have systemctl entries for these daemons.
For now we have one hack that we need to find the exact name of the service from `/var/lib/ceph/$fsid` path and then construct the systemctl command to start the daemon.

For example for mon:


This is the exact name "mon.ceph-testing-1624859654614-node1-installer-mon-mgr-osd-node-exp" for mon from the following path:
/var/lib/ceph/f64f341c-655d-11eb-8778-fa163e914bcc/mon.ceph-testing-1624859654614-node1-installer-mon-mgr-osd-node-exp

Construct the systemctl command:

systemctl start ceph-f64f341c-655d-11eb-8778-fa163e914bcc@mon.ceph-testing-1624859654614-node1-installer-mon-mgr-osd-node-exp

History

#1 Updated by Sebastian Wagner 5 months ago

  • Status changed from New to Closed

not a bug

Also available in: Atom PDF