Project

General

Profile

Bug #51182

pybind/mgr/snap_schedule: Invalid command: Unexpected argument 'fs=cephfs'

Added by Patrick Donnelly over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/snap_schedule, qa-suite
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-06-11T18:56:12.439 DEBUG:teuthology.orchestra.run.smithi184:> sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 120 ceph --cluster ceph fs snap-schedule list path=snap_test_dir1 format=json fs=cephfs
...
2021-06-11T18:56:12.745 INFO:teuthology.orchestra.run.smithi184.stderr:Invalid command: Unexpected argument 'fs=cephfs'
2021-06-11T18:56:12.746 INFO:teuthology.orchestra.run.smithi184.stderr:fs snap-schedule list <path> [<subvol>] [--recursive] [--fs <value>] [--format <value>] :  Get current snapshot schedule for <path>
2021-06-11T18:56:12.746 INFO:teuthology.orchestra.run.smithi184.stderr:Error EINVAL: invalid command
2021-06-11T18:56:12.748 DEBUG:teuthology.orchestra.run:got remote process result: 22

From: /ceph/teuthology-archive/pdonnell-2021-06-11_18:02:10-fs-wip-pdonnell-testing-20210611.162716-distro-basic-smithi/6166714/teuthology.log

Might be related to #51145 or caused by the same regression.


Related issues

Related to Ceph - Bug #51145: pybind/cmd_argparse: does not process vector of choices Resolved
Copied to CephFS - Backport #51231: pacific: pybind/mgr/snap_schedule: Invalid command: Unexpected argument 'fs=cephfs' Resolved

History

#1 Updated by Patrick Donnelly over 1 year ago

  • Related to Bug #51145: pybind/cmd_argparse: does not process vector of choices added

#2 Updated by Patrick Donnelly over 1 year ago

  • Subject changed from pybind/mgr/snap_schedule: to pybind/mgr/snap_schedule: Invalid command: Unexpected argument 'fs=cephfs'

#3 Updated by Patrick Donnelly over 1 year ago

  • Status changed from New to Triaged
  • Assignee set to Patrick Donnelly

#4 Updated by Patrick Donnelly over 1 year ago

  • Status changed from Triaged to In Progress

#5 Updated by Patrick Donnelly over 1 year ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 41840

#6 Updated by Patrick Donnelly over 1 year ago

  • Backport set to pacific

#7 Updated by Patrick Donnelly over 1 year ago

  • Status changed from Fix Under Review to Pending Backport

#8 Updated by Backport Bot over 1 year ago

  • Copied to Backport #51231: pacific: pybind/mgr/snap_schedule: Invalid command: Unexpected argument 'fs=cephfs' added

#9 Updated by Loïc Dachary over 1 year ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF