Project

General

Profile

Bug #51102

RuntimeError: uid/gid not found in "rados/thrash-old-clients" test

Added by Kefu Chai over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-06-05T03:32:35.040 DEBUG:teuthology.orchestra.run.smithi058:> sudo /home/ubuntu/cephtest/cephadm --image quay.ceph.io/ceph-ci/ceph:a453d2697c6f89d8281ea5420af1f1b376dd959c shell -c /etc/ceph/ceph.conf -k /etc/ceph/ceph.client.admin.keyring --fsid 1a2e3eae-c5ae-11eb-8
c12-001a4aab830c -- ceph mon dump -f json
2021-06-05T03:32:36.660 INFO:teuthology.orchestra.run.smithi058.stderr:Non-zero exit code 127 from /bin/podman run --rm --ipc=host --stop-signal=SIGTERM --net=host --entrypoint stat --init -e CONTAINER_IMAGE=quay.ceph.io/ceph-ci/ceph:a453d2697c6f89d8281ea5420af1f1b376dd95
9c -e NODE_NAME=smithi058 -e CEPH_USE_RANDOM_NONCE=1 quay.ceph.io/ceph-ci/ceph:a453d2697c6f89d8281ea5420af1f1b376dd959c -c %u %g /var/lib/ceph
2021-06-05T03:32:36.660 INFO:teuthology.orchestra.run.smithi058.stderr:stat: stderr Error: OCI runtime error: container_linux.go:370: starting container process caused: process_linux.go:459: container init caused: process_linux.go:422: setting cgroup config for procHooks
process caused: Unit libpod-4a8d674bc52249c3ec9342de2e12f13dc5d10edd8c8baf69c601df11dcf6640d.scope not found.
2021-06-05T03:32:36.665 INFO:teuthology.orchestra.run.smithi058.stderr:Traceback (most recent call last):
2021-06-05T03:32:36.665 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 8235, in <module>
2021-06-05T03:32:36.665 INFO:teuthology.orchestra.run.smithi058.stderr:    main()
2021-06-05T03:32:36.666 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 8223, in main
2021-06-05T03:32:36.666 INFO:teuthology.orchestra.run.smithi058.stderr:    r = ctx.func(ctx)
2021-06-05T03:32:36.666 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1644, in _infer_fsid
2021-06-05T03:32:36.666 INFO:teuthology.orchestra.run.smithi058.stderr:    return func(ctx)
2021-06-05T03:32:36.666 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1681, in _infer_config
2021-06-05T03:32:36.667 INFO:teuthology.orchestra.run.smithi058.stderr:    return func(ctx)
2021-06-05T03:32:36.667 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1728, in _infer_image
2021-06-05T03:32:36.667 INFO:teuthology.orchestra.run.smithi058.stderr:    return func(ctx)
2021-06-05T03:32:36.667 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 4468, in command_shell
2021-06-05T03:32:36.667 INFO:teuthology.orchestra.run.smithi058.stderr:    make_log_dir(ctx, ctx.fsid)
2021-06-05T03:32:36.668 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 1830, in make_log_dir
2021-06-05T03:32:36.668 INFO:teuthology.orchestra.run.smithi058.stderr:    uid, gid = extract_uid_gid(ctx)
2021-06-05T03:32:36.668 INFO:teuthology.orchestra.run.smithi058.stderr:  File "/home/ubuntu/cephtest/cephadm", line 2550, in extract_uid_gid
2021-06-05T03:32:36.668 INFO:teuthology.orchestra.run.smithi058.stderr:    raise RuntimeError('uid/gid not found')
2021-06-05T03:32:36.668 INFO:teuthology.orchestra.run.smithi058.stderr:RuntimeError: uid/gid not found
2021-06-05T03:32:36.684 DEBUG:teuthology.orchestra.run:got remote process result: 1
2021-06-05T03:32:36.685 ERROR:teuthology.contextutil:Saw exception from nested tasks

/a/kchai-2021-06-05_02:55:59-rados-wip-kefu-testing-2021-06-05-0940-distro-basic-smithi/6153792


Related issues

Duplicates Orchestrator - Bug #49287: podman: setting cgroup config for procHooks process caused: Unit libpod-$hash.scope not found New

History

#1 Updated by Kefu Chai over 2 years ago

  • Related to Bug #50399: cephadm ignores registry settings added

#2 Updated by Kefu Chai over 2 years ago

looks like #50399, but seems they are different.

#3 Updated by Sebastian Wagner over 2 years ago

  • Category set to cephadm

#4 Updated by Kamoltat (Junior) Sirivadhna over 2 years ago

spotted again at /a/ksirivad-2021-07-11_01:45:00-rados-wip-pg-autoscaler-overlap-distro-basic-smithi/6263029/

#5 Updated by Sebastian Wagner over 2 years ago

  • Duplicates Bug #49287: podman: setting cgroup config for procHooks process caused: Unit libpod-$hash.scope not found added

#6 Updated by Sebastian Wagner over 2 years ago

  • Related to deleted (Bug #50399: cephadm ignores registry settings)

#7 Updated by Sebastian Wagner over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF