Project

General

Profile

Bug #51078

rgw: completion of multipart upload leaves delete marker

Added by J. Eric Ivancich 16 days ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Target version:
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The multipart upload meta object is deleted when the multipart upload is completed. When the bucket is versioned, it needs to be deleted from the bucket index rather than go through versioning delete process that adds a delete marker to the bucket index rather than simply removing it from the bucket index.


Related issues

Copied to rgw - Backport #51138: pacific: rgw: completion of multipart upload leaves delete marker Resolved

History

#1 Updated by J. Eric Ivancich 16 days ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 41678

#2 Updated by J. Eric Ivancich 16 days ago

Due to zipper changes, this is a non-trivial backport to pacific. I'm happy to do it.

#3 Updated by J. Eric Ivancich 16 days ago

The pacific backport can be found on the branch https://github.com/ivancich/ceph-fork/tree/pacific-multipart-delete-marker .

#4 Updated by J. Eric Ivancich 11 days ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Backport Bot 11 days ago

  • Copied to Backport #51138: pacific: rgw: completion of multipart upload leaves delete marker added

#6 Updated by Loïc Dachary 4 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF