Project

General

Profile

Bug #51000

LibRadosTwoPoolsPP.ManifestSnapRefcount failure

Added by Kefu Chai over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-05-27T09:58:33.240 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp: [ RUN      ] LibRadosTwoPoolsPP.ManifestSnapRefcount
2021-05-27T09:58:33.240 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp: require_osd_release = quincy
2021-05-27T09:58:33.241 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp: /build/ceph-17.0.0-4676-gdc82a0fc/src/test/librados/tier_cxx.cc:3658: Failure
2021-05-27T09:58:33.241 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp: Expected equality of these values:
2021-05-27T09:58:33.241 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp:   1u
2021-05-27T09:58:33.241 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp:     Which is: 1
2021-05-27T09:58:33.241 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp:   refs.count()
2021-05-27T09:58:33.242 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp:     Which is: 2
2021-05-27T09:58:33.242 INFO:tasks.workunit.client.0.smithi134.stdout:              api_tier_pp: [  FAILED  ] LibRadosTwoPoolsPP.ManifestSnapRefcount (10033 ms)

/a//kchai-2021-05-27_09:22:11-rados-wip-kefu-testing-2021-05-27-1528-distro-basic-smithi/6137821/

i reran the failed test locally with the code (same sha1), but could not reproduce this issue


Related issues

Copied to RADOS - Backport #52322: pacific: LibRadosTwoPoolsPP.ManifestSnapRefcount failure Resolved

History

#1 Updated by Neha Ojha over 2 years ago

  • Backport set to pacific

similar failure seen in pacific

2021-07-04T15:42:10.778 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp: [ RUN      ] LibRadosTwoPoolsPP.ManifestSnapRefcount
2021-07-04T15:42:10.778 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp: require_osd_release = pacific
2021-07-04T15:42:10.778 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp: /home/jenkins-build/build/workspace/ceph-dev-build/ARCH/x86_64/AVAILABLE_ARCH/x86_64/AVAILABLE_DIST/centos8/DIST/centos8/MACHINE_SIZE/gigantic/release/16.2.4-666-g283df107/rpm/el8/BUILD/ceph-16.2.4-666-g283df107/src/test/librados/tier_cxx.cc:3613: Failure
2021-07-04T15:42:10.778 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp: Expected equality of these values:
2021-07-04T15:42:10.779 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp:   2u
2021-07-04T15:42:10.779 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp:     Which is: 2
2021-07-04T15:42:10.779 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp:   refs.count()
2021-07-04T15:42:10.779 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp:     Which is: 3
2021-07-04T15:42:10.779 INFO:tasks.workunit.client.0.smithi050.stdout:              api_tier_pp: [  FAILED  ] LibRadosTwoPoolsPP.ManifestSnapRefcount (161420 ms)

/a/yuriw-2021-07-04_14:35:40-rados-pacific-distro-basic-smithi/6252312

#2 Updated by Neha Ojha over 2 years ago

  • Assignee set to Myoungwon Oh

Myoungwon Oh, can you please help take a look at this.

#3 Updated by Myoungwon Oh over 2 years ago

Ok, I'll take a look.

#4 Updated by Myoungwon Oh over 2 years ago

  • Status changed from New to In Progress

#5 Updated by Neha Ojha over 2 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 42302

#6 Updated by Neha Ojha over 2 years ago

Myoungwon Oh wrote:

Ok, I'll take a look.

thanks!

#7 Updated by Kefu Chai over 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#8 Updated by Backport Bot over 2 years ago

  • Copied to Backport #52322: pacific: LibRadosTwoPoolsPP.ManifestSnapRefcount failure added

#9 Updated by Loïc Dachary over 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF