Project

General

Profile

Bug #50870

qa: test_full: "rm: cannot remove 'large_file_a': Permission denied"

Added by Patrick Donnelly about 1 month ago. Updated 29 days ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-05-18T06:43:36.315 DEBUG:teuthology.orchestra.run.smithi063:> (cd /home/ubuntu/cephtest/mnt.0 && exec sudo rm -f large_file_a)
2021-05-18T06:43:36.415 INFO:teuthology.orchestra.run.smithi063.stderr:rm: cannot remove 'large_file_a': Permission denied
2021-05-18T06:43:36.421 DEBUG:teuthology.orchestra.run:got remote process result: 1

From: /ceph/teuthology-archive/pdonnell-2021-05-18_06:01:30-fs-wip-pdonnell-testing-20210518.025642-distro-basic-smithi/6119669/teuthology.log

and /ceph/teuthology-archive/pdonnell-2021-05-18_06:01:30-fs-wip-pdonnell-testing-20210518.025642-distro-basic-smithi/6119865/teuthology.log

mds log:

2021-05-18T08:32:32.865+0000 7fd48e5a5700  7 mds.0.server dispatch_client_request client_request(client.4934:9 unlink #0x1/large_file_a 2021-05-18T08:32:32.864915+0000 caller_uid=0, caller_gid=0{}) v2
2021-05-18T08:32:32.865+0000 7fd48e5a5700 20 Session check_access path
2021-05-18T08:32:32.865+0000 7fd48e5a5700  7 mds.0.server reply_client_request -13 ((13) Permission denied) client_request(client.4934:9 unlink #0x1/large_file_a 2021-05-18T08:32:32.864915+0000 caller_uid=0, caller_gid=0{}) v2

from: /ceph/teuthology-archive/pdonnell-2021-05-18_06:01:30-fs-wip-pdonnell-testing-20210518.025642-distro-basic-smithi/6119865/remote/smithi116/log/ceph-mds.b.log.gz

Doesn't look caused by the PR being tested to fix other issues with full tests: https://github.com/ceph/ceph/pull/41025

Probably #41025 fixed the failures masking this one.

History

#1 Updated by Patrick Donnelly about 1 month ago

  • Status changed from New to Triaged
  • Assignee set to Xiubo Li

Xiubo, please take a look at this one. It might be something to do with the caps but that'd be weird.

#3 Updated by Patrick Donnelly about 1 month ago

  • Status changed from Triaged to Need More Info
  • Assignee deleted (Xiubo Li)

Nevermind Xiubo.

#4 Updated by Xiubo Li 29 days ago

Patrick Donnelly wrote:

Xiubo, please take a look at this one. It might be something to do with the caps but that'd be weird.

Sure, will check it.

#5 Updated by Patrick Donnelly 29 days ago

  • Status changed from Need More Info to Closed

This issue was caused by a bug in the aforementioned PR. No need to work on this Xiubo.

Also available in: Atom PDF