Project

General

Profile

Bug #50621

rgw: fix bucket object listing when initial marker matches prefix

Added by J. Eric Ivancich 10 days ago. Updated 5 days ago.

Status:
Pending Backport
Priority:
Normal
Target version:
% Done:

0%

Source:
Tags:
Backport:
pacific, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When using a delimiter listing on a bucket, when a marker that matches the prefix is provided, no listing will be provided.

Steps to Reproduce:
1. Create a bucket and add an object named "dir1/obj2".
2. Issue a listing of the bucket with a delimiter ("/") with prefix ("dir1/") with marker ("dir/").

Ganesha apparently sets the marker where s3cmd does not, which is why this bug has not yet been discovered.


Related issues

Copied to rgw - Backport #50708: pacific: rgw: fix bucket object listing when initial marker matches prefix New
Copied to rgw - Backport #50709: octopus: rgw: fix bucket object listing when initial marker matches prefix New

History

#1 Updated by J. Eric Ivancich 9 days ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 41141

#2 Updated by J. Eric Ivancich 9 days ago

  • Backport changed from yes, tbd to pacific, octopus

#3 Updated by J. Eric Ivancich 5 days ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot 5 days ago

  • Copied to Backport #50708: pacific: rgw: fix bucket object listing when initial marker matches prefix added

#5 Updated by Backport Bot 5 days ago

  • Copied to Backport #50709: octopus: rgw: fix bucket object listing when initial marker matches prefix added

Also available in: Atom PDF