Project

General

Profile

Bug #50393

CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/ceph...

Added by Sentry Bot 5 months ago. Updated 8 days ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
Tests
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
pacific, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://sentry.ceph.com/organizations/ceph/issues/7316/

CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=9ab9efc0235132989fe1f482d604b61d10225154 TESTDIR="/home/ubuntu/cephtest" CEPH_ARGS="--cluster ceph" CEPH_ID="0" PATH=$PATH:/usr/sbin CEPH_BASE=/home/ubuntu/cephtest/clone.client.0 CEPH_ROOT=/home/ubuntu/cephtest/clone.client.0 adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 3h /home/ubuntu/cephtest/clone.client.0/qa/wo...
(8 additional frame(s) were not displayed)
...
  File "tasks/workunit.py", line 425, in _run_tests
    label="workunit test {workunit}".format(workunit=workunit)
  File "teuthology/orchestra/remote.py", line 215, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "teuthology/orchestra/run.py", line 455, in run
    r.wait()
  File "teuthology/orchestra/run.py", line 161, in wait
    self._raise_for_status()
  File "teuthology/orchestra/run.py", line 179, in _raise_for_status
    raise CommandCrashedError(command=self.command)

Related issues

Copied to RADOS - Backport #51570: pacific: CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/ceph... Resolved
Copied to RADOS - Backport #51741: octopus: CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/ceph... New

History

#1 Updated by Kefu Chai 5 months ago

mon/test_mon_config_key.py

/a/kchai-2021-04-15_08:31:03-rados-wip-kefu-testing-2021-04-15-1359-distro-basic-smithi/6048481/

#2 Updated by Kefu Chai 5 months ago

  • Project changed from Ceph to RADOS
  • Category set to Tests
  • Status changed from New to Fix Under Review
  • Assignee set to Kefu Chai
  • Pull request ID set to 40881

#3 Updated by Kefu Chai 5 months ago

  • Status changed from Fix Under Review to Resolved

#4 Updated by Neha Ojha 3 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to pacific
2021-07-04T17:41:59.347 DEBUG:teuthology.orchestra.run:got remote process result: None
2021-07-04T17:41:59.348 INFO:tasks.workunit:Stopping ['mon/test_mon_config_key.py'] on client.0...
2021-07-04T17:41:59.349 DEBUG:teuthology.orchestra.run.smithi005:> sudo rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0
2021-07-04T17:41:59.896 INFO:tasks.ceph.osd.2.smithi005.stderr:2021-07-04T17:41:59.890+0000 7fef27737700 -1 osd.2 12 heartbeat_check: no reply from 172.21.15.5:6802 osd.0 since back 2021-07-04T17:37:40.991617+0000 front 2021-07-04T17:35:41.756905+0000 (oldest deadline 2021-07-04T17:35:54.679931+0000)
2021-07-04T17:42:04.833 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/run_tasks.py", line 91, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/run_tasks.py", line 70, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/github.com_ceph_ceph_283df1071a4c03b56eba700b1fcc721dbaf6bc3d/qa/tasks/workunit.py", line 147, in task
    cleanup=cleanup)
  File "/home/teuthworker/src/github.com_ceph_ceph_283df1071a4c03b56eba700b1fcc721dbaf6bc3d/qa/tasks/workunit.py", line 297, in _spawn_on_all_clients
    timeout=timeout)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/parallel.py", line 84, in __exit__
    for result in self:
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/parallel.py", line 98, in __next__
    resurrect_traceback(result)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/parallel.py", line 30, in resurrect_traceback
    raise exc.exc_info[1]
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/parallel.py", line 23, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/github.com_ceph_ceph_283df1071a4c03b56eba700b1fcc721dbaf6bc3d/qa/tasks/workunit.py", line 426, in _run_tests
    label="workunit test {workunit}".format(workunit=workunit)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/orchestra/remote.py", line 509, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/orchestra/run.py", line 455, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/orchestra/run.py", line 161, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_26631ede9027a5643f2e47dacc5af6f1834aac45/teuthology/orchestra/run.py", line 179, in _raise_for_status
    raise CommandCrashedError(command=self.command)
teuthology.exceptions.CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=283df1071a4c03b56eba700b1fcc721dbaf6bc3d TESTDIR="/home/ubuntu/cephtest" CEPH_ARGS="--cluster ceph" CEPH_ID="0" PATH=$PATH:/usr/sbin CEPH_BASE=/home/ubuntu/cephtest/clone.client.0 CEPH_ROOT=/home/ubuntu/cephtest/clone.client.0 CEPH_MNT=/home/ubuntu/cephtest/mnt.0 adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 3h /home/ubuntu/cephtest/clone.client.0/qa/workunits/mon/test_mon_config_key.py'
2021-07-04T17:42:04.929 ERROR:teuthology.run_tasks: Sentry event: https://sentry.ceph.com/organizations/ceph/?query=9f69c335c4f849bb859e26e0f731457c

/a/yuriw-2021-07-04_14:35:40-rados-pacific-distro-basic-smithi/6252327

#5 Updated by Backport Bot 3 months ago

  • Copied to Backport #51570: pacific: CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/ceph... added

#6 Updated by Deepika Upadhyay 2 months ago

  • Backport changed from pacific to pacific, octopus

/ceph/teuthology-archive/yuriw-2021-07-16_17:39:36-rados-wip-yuri7-testing-2021-07-16-0906-octopus-distro-basic-smithi/6276330/teuthology.log

#7 Updated by Backport Bot 2 months ago

  • Copied to Backport #51741: octopus: CommandCrashedError: Command crashed: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/ceph... added

Also available in: Atom PDF