Project

General

Profile

Bug #50342

test: compile errors

Added by Patrick Donnelly about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

[750/1017] Building CXX object src/test/librados/CMakeFiles/ceph_test_rados_api_tier_pp.dir/tier_cxx.cc.o
../src/test/librados/tier_cxx.cc: In member function ‘virtual void LibRadosTwoPoolsPP_EvictSnapRollbackReadRace_Test::TestBody()’:
../src/test/librados/tier_cxx.cc:1590:33: warning: ‘int librados::v14_2_0::AioCompletion::wait_for_safe()’ is deprecated [-Wdeprecated-declarations]
       completion->wait_for_safe();
                                 ^
In file included from ../src/test/librados/tier_cxx.cc:8:
../src/include/rados/librados.hpp:201:9: note: declared here
     int wait_for_safe() __attribute__ ((deprecated));
         ^~~~~~~~~~~~~
../src/test/librados/tier_cxx.cc:1594:34: warning: ‘int librados::v14_2_0::AioCompletion::wait_for_safe()’ is deprecated [-Wdeprecated-declarations]
       completion1->wait_for_safe();
                                  ^
In file included from ../src/test/librados/tier_cxx.cc:8:
../src/include/rados/librados.hpp:201:9: note: declared here
     int wait_for_safe() __attribute__ ((deprecated));
         ^~~~~~~~~~~~~
../src/test/librados/tier_cxx.cc:1608:33: warning: ‘int librados::v14_2_0::AioCompletion::wait_for_safe()’ is deprecated [-Wdeprecated-declarations]
       completion->wait_for_safe();
                                 ^
In file included from ../src/test/librados/tier_cxx.cc:8:
../src/include/rados/librados.hpp:201:9: note: declared here
     int wait_for_safe() __attribute__ ((deprecated));
         ^~~~~~~~~~~~~
[1017/1017] Linking CXX executable bin/ceph-osd

Regression caused by: https://github.com/ceph/ceph/pull/40067

History

#2 Updated by Samuel Just about 1 month ago

  • Assignee set to Samuel Just

#3 Updated by Patrick Donnelly about 1 month ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 40833

#4 Updated by Patrick Donnelly about 1 month ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF