Project

General

Profile

Bug #50259

Makefile failing on focal

Added by Harish Munjulur almost 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

11% tests passed, 185 tests failed out of 207

Total Test time (real) = 3836.86 sec

The following tests FAILED:
3 - run-tox-mgr (Failed)
16 - run-rbd-unit-tests-N.sh (Failed)
17 - run-rbd-unit-tests-0.sh (Failed)
18 - run-rbd-unit-tests-1.sh (Failed)
19 - run-rbd-unit-tests-61.sh (Failed)
20 - run-rbd-unit-tests-109.sh (Failed)
21 - run-rbd-unit-tests-127.sh (Failed)
22 - run-cli-tests (Failed)
23 - smoke.sh (Failed)
25 - unittest_admin_socket (Not Run)
...
204 - unittest_rbd_mirror (Not Run)

makelogfile_wip2.txt View (124 KB) Harish Munjulur, 04/08/2021 08:36 PM

History

#1 Updated by Brad Hubbard almost 2 years ago

21: /root/wip-hmunjulu02-testing/src/test/run-rbd-unit-tests.sh: line 22: unittest_librbd: command not found
 21/207 Test  #21: run-rbd-unit-tests-127.sh ...............***Failed    0.01 sec

unittest_librbd does not exist so the build is incomplete. So it looks like several of the rbd binaries (at least) were not built before these tests were run.

#2 Updated by Brad Hubbard almost 2 years ago

  • Assignee set to Brad Hubbard
  • Source set to Q/A

#3 Updated by Brad Hubbard almost 2 years ago

  • Status changed from New to Triaged
  • Priority changed from Normal to Low
  • Severity changed from 3 - minor to 4 - irritation

#4 Updated by Yuri Weinstein almost 2 years ago

The problem was that we did not use ninja instead of make for these tests on master and build was incomplete, thx @Brad for helping with this !

#5 Updated by Yuri Weinstein almost 2 years ago

  • Status changed from Triaged to Resolved

#6 Updated by Ronen Friedman 6 months ago

:

For some reason, we now have a similar set of failures:
https://jenkins.ceph.com/job/ceph-pull-requests/101821/
projectroot.src.test.run_rbd_unit_tests_1.sh
projectroot.src.test.run_rbd_unit_tests_61.sh
projectroot.src.test.run_rbd_unit_tests_109.sh
projectroot.src.test.run_rbd_unit_tests_127.sh

Also available in: Atom PDF