Project

General

Profile

Bug #50178

qa: "TypeError: run() got an unexpected keyword argument 'shell'"

Added by Patrick Donnelly 8 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-04-01T02:55:55.619 INFO:tasks.cephfs_test_runner:======================================================================
2021-04-01T02:55:55.620 INFO:tasks.cephfs_test_runner:ERROR: test_backtrace_repair (tasks.cephfs.test_forward_scrub.TestForwardScrub)
2021-04-01T02:55:55.620 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2021-04-01T02:55:55.621 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2021-04-01T02:55:55.621 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_5c92bde19d0b1ad5e2a680f5925b00ec1f942c7d/qa/tasks/cephfs/test_forward_scrub.py", line 291, in test_backtrace_repair
2021-04-01T02:55:55.622 INFO:tasks.cephfs_test_runner:    with self.assert_cluster_log("bad backtrace on inode"):
2021-04-01T02:55:55.622 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_5c92bde19d0b1ad5e2a680f5925b00ec1f942c7d/qa/tasks/ceph_test_case.py", line 116, in __enter__
2021-04-01T02:55:55.623 INFO:tasks.cephfs_test_runner:    shell=False)
2021-04-01T02:55:55.624 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_5c92bde19d0b1ad5e2a680f5925b00ec1f942c7d/qa/tasks/ceph_manager.py", line 1593, in run_ceph_w
2021-04-01T02:55:55.625 INFO:tasks.cephfs_test_runner:    stdin=run.PIPE, shell=shell)
2021-04-01T02:55:55.626 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_85d61eae4759f46ce21e9a37cd816a7a1a66c9d5/teuthology/orchestra/remote.py", line 215, in run
2021-04-01T02:55:55.626 INFO:tasks.cephfs_test_runner:    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
2021-04-01T02:55:55.627 INFO:tasks.cephfs_test_runner:TypeError: run() got an unexpected keyword argument 'shell'

From: /ceph/teuthology-archive/pdonnell-2021-04-01_00:45:34-fs-wip-pdonnell-testing-20210331.222326-distro-basic-smithi/6014089/teuthology.log

Caused by: https://github.com/ceph/ceph/pull/38443

History

#1 Updated by Patrick Donnelly 8 months ago

  • Description updated (diff)

#2 Updated by Rishabh Dave 8 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 1639

#3 Updated by Rishabh Dave 8 months ago

  • Pull request ID deleted (1639)

#4 Updated by Patrick Donnelly 6 months ago

  • Status changed from Fix Under Review to Rejected

Caused by testing #38481

Also available in: Atom PDF