Project

General

Profile

Bug #50043

cephadm: account for possible "." in patch portion of ceph version

Added by Adam King about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

It's possible when making custom ceph images (for downstream for example) to get 'ceph --version' output like

ceph version 16.1.0-1084.el8cp (899d93a5c7913d6952438f4b48d29d1cef2aaa2a) pacific (rc)

In this case, upgrading to this image will fail (very badly, the whole cephadm module fails) because the upgrade tries to parse "16.1.0-1084.el8cp" and expects only 2 instances of "." when there are three. As long as the major and minor versions are fine I see no reason to be strict about what's in the "patch" section of the version, even if it contains a ".".

History

#1 Updated by Adam King about 1 month ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 40478

#2 Updated by Sage Weil about 1 month ago

  • Status changed from Fix Under Review to Resolved

#3 Updated by Ken Dreyer about 1 month ago

Backported to Pacific in https://github.com/ceph/ceph/pull/40544 , will be released in v16.2.1.

Also available in: Atom PDF