Project

General

Profile

Bug #49988

Global Recovery Event never completes

Added by Sage Weil 3 months ago. Updated about 20 hours ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

  services:
    mon: 3 daemons, quorum a,b,c (age 29m)
    mgr: x(active, since 29m)
    osd: 6 osds: 6 up (since 17m), 6 in (since 29m)

  data:
    pools:   3 pools, 160 pgs
    objects: 0 objects, 0 B
    usage:   6.1 GiB used, 600 GiB / 606 GiB avail
    pgs:     160 active+clean

  progress:
    Global Recovery Event (5m)
      [==================..........] (remaining: 2m)


this is a OSD=6 vstart cluster that just ran qa/workunits/rados/test_python.sh, but i've seen this in other cases too.

Related issues

Duplicated by mgr - Bug #50243: test_turn_off_module (tasks.mgr.test_progress.TestProgress) AssertionError: False is not true Duplicate

History

#1 Updated by Neha Ojha 3 months ago

  • Assignee set to Kamoltat Sirivadhna

#2 Updated by Kamoltat Sirivadhna 2 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 40480

Problem was that I did not subtract pgs that I skip because (reported_epoch_of_pg < start_epoch_of_event) from total_pg_num, this results in always (active_clean_pg < total_pg_num).
Therefore, a fix for this is just to subtract the pgs I skipped from total_pg_num.

#3 Updated by Neha Ojha about 1 month ago

  • Related to Bug #50243: test_turn_off_module (tasks.mgr.test_progress.TestProgress) AssertionError: False is not true added

#4 Updated by Kefu Chai 19 days ago

  • Related to deleted (Bug #50243: test_turn_off_module (tasks.mgr.test_progress.TestProgress) AssertionError: False is not true)

#5 Updated by Kefu Chai 19 days ago

  • Duplicated by Bug #50243: test_turn_off_module (tasks.mgr.test_progress.TestProgress) AssertionError: False is not true added

#6 Updated by Kefu Chai about 20 hours ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF