Project

General

Profile

Bug #49883

librados: hang in RadosClient::wait_for_osdmap

Added by Patrick Donnelly about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Monitor, librados
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://pulpito.ceph.com/pdonnell-2021-03-18_06:53:09-rados:basic-wip-pdonnell-testing-20210318.035227-distro-basic-smithi/

10 hung jobs. Nothing particular to libcephsqlite which I was testing as it hangs early in pool creation for the unit test: https://github.com/ceph/ceph/pull/39191/files#diff-e7c4058c8c56f59ef928a794cf6e692958656639def26dfade16a7504f6d9ca8R77

(gdb) bt
#0  0x00007f7b462042fc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7b4423c8f0 in std::condition_variable::wait(std::unique_lock<std::mutex>&) () from /lib64/libstdc++.so.6
#2  0x00007f7b474a299d in librados::v14_2_0::RadosClient::wait_for_osdmap() () from /lib64/librados.so.2
#3  0x00007f7b474a3720 in librados::v14_2_0::RadosClient::pool_create(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, short) () from /lib64/librados.so.2
#4  0x00007f7b4746fc82 in librados::v14_2_0::Rados::pool_create(char const*) () from /lib64/librados.so.2
#5  0x000055fc4920f7cf in CephSQLiteTest::SetUpTestSuite() ()
#6  0x000055fc4925456e in void testing::internal::HandleExceptionsInMethodIfSupported<testing::TestSuite, void>(testing::TestSuite*, void (testing::TestSuite::*)(), char const*) ()
#7  0x000055fc49247625 in testing::TestSuite::Run() ()
#8  0x000055fc49249265 in testing::internal::UnitTestImpl::RunAllTests() ()
#9  0x000055fc4925473e in bool testing::internal::HandleExceptionsInMethodIfSupported<testing::internal::UnitTestImpl, bool>(testing::internal::UnitTestImpl*, bool (testing::internal::UnitTestImpl::*)(), char const*) ()
#10 0x000055fc492471c0 in testing::UnitTest::Run() ()
#11 0x000055fc491f8e49 in main ()

ceph-client.libcephsqlite.38006.log.gz (5.54 KB) Patrick Donnelly, 03/18/2021 02:35 PM

History

#2 Updated by Patrick Donnelly about 1 month ago

The ubuntu jobs are failing because the ceph-mgr can't find libcephsqlite.so. There were packaging changes that probably explain that. It may be related to this somehow.

#3 Updated by Patrick Donnelly about 1 month ago

  • Status changed from New to Rejected

This turned out to be because the auth credential had wrong permissions (due to a profile name change).

Also available in: Atom PDF