Project

General

Profile

Bug #49737

cephadm bootstrap --skip-ssh skips too much

Added by Sebastian Wagner over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

50%

Source:
Tags:
low-hanging-fruit
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

--skip-ssh should only disable the SSH configs. It should still enable the cephadm mgr module.

This is a usability bug.

https://lists.ceph.io/hyperkitty/list/ceph-users@ceph.io/thread/5K3CTLZUBHQDVZGP5BDMI3B6ZBVDTETO/

History

#1 Updated by Sebastian Wagner over 1 year ago

  • Description updated (diff)

#2 Updated by Shreya Sharma over 1 year ago

Can I take this issue?

#3 Updated by Sebastian Wagner over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Shreya Sharma

sure!

#4 Updated by Shreya Sharma over 1 year ago

Can you point me to the relevant code/files if possible?

#5 Updated by Shreya Sharma over 1 year ago

  • % Done changed from 0 to 50
  • Pull request ID set to 40319

#6 Updated by Shreya Sharma over 1 year ago

I think I've found and fixed the bug but I'm not able to reproduce the problem. How can I test it?

#7 Updated by Kefu Chai over 1 year ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF