Project

General

Profile

Bug #49556

Master RPM builds in OBS failing due to OOM (regression)

Added by Nathan Cutler almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

43b441f9a3bc907c17d52385251001ffcd5d3ff9 removed a bunch of code that was protecting OBS builds from OOM by setting build parallelism on the basis of available memory instead of the number of CPU threads the build hardware can sustain.

This commit also introduced the use of the %_smb_build_ncpus macro, which is not available in any SUSE operating system except Tumbleweed (because only very recent versions of RPM define this macro).

Something will need to be done to restore the "good build behavior" we had the OBS before this regression.

History

#1 Updated by Nathan Cutler almost 2 years ago

  • Subject changed from Replacement "_smp_build_ncpus" calculation logic broken to RPM: spec file is trying to use %_smp_build_ncpus in Leap 15.2 which has RPM 4.14.1
  • Description updated (diff)

#2 Updated by Nathan Cutler almost 2 years ago

  • Assignee deleted (Nathan Cutler)

#3 Updated by Nathan Cutler almost 2 years ago

  • Subject changed from RPM: spec file is trying to use %_smp_build_ncpus in Leap 15.2 which has RPM 4.14.1 to Master RPM build OOMing in OBS (regression)
  • Description updated (diff)
  • Status changed from New to Fix Under Review
  • Assignee set to Nathan Cutler
  • Pull request ID set to 39765

#4 Updated by Nathan Cutler almost 2 years ago

  • Subject changed from Master RPM build OOMing in OBS (regression) to Master RPM builds in OBS failing due to OOM (regression)

#5 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF