Project

General

Profile

Bug #49464

qa: rank_freeze prevents failover on some tests

Added by Patrick Donnelly about 2 months ago. Updated 19 days ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
pacific
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDSMonitor
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-02-21T20:20:58.902 INFO:tasks.cephfs_test_runner:======================================================================
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:ERROR: test_snapclient_cache (tasks.cephfs.test_snapshots.TestSnapshots)
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph_963d854aba2d8969ed239500ad8f88439f7451db/qa/tasks/cephfs/test_snapshots.py", line 312, in test_snapclient_cache
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:    self.wait_until_true(lambda: proc.finished, timeout=30);
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph_963d854aba2d8969ed239500ad8f88439f7451db/qa/tasks/ceph_test_case.py", line 196, in wait_until_true
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:    raise TestTimeoutError("Timed out after {0}s".format(elapsed))
2021-02-21T20:20:58.903 INFO:tasks.cephfs_test_runner:tasks.ceph_test_case.TestTimeoutError: Timed out after 30s

From: /ceph/teuthology-archive/teuthology-2021-02-21_03:15:03-fs-master-distro-basic-gibba/5899612/teuthology.log

cause:

2021-02-21T20:20:21.275+0000 7feee5359700  7 mon.a@0(leader).mds e97 prepare_update mon_command({"prefix": "mds fail", "role_or_gid": "10:2"} v 0) v1
2021-02-21T20:20:21.275+0000 7feee5359700  4 mon.a@0(leader).mds e97 filesystem_command prefix='mds fail'
2021-02-21T20:20:21.275+0000 7feee5359700 10 mon.a@0(leader).mds e97 gid_from_arg: validated rank/GID 10:2 as a rank
2021-02-21T20:20:21.275+0000 7feee5359700 10 mon.a@0(leader).mds e97 gid_from_arg: validated rank/GID 10:2 as a rank
2021-02-21T20:20:21.275+0000 7feee5359700  1 mon.a@0(leader).mds e97 fail_mds_gid 7623 mds.c role 2
2021-02-21T20:20:21.275+0000 7feee5359700  1 mon.a@0(leader).mds e97 mds is frozen

From: /ceph/teuthology-archive/teuthology-2021-02-21_03:15:03-fs-master-distro-basic-gibba/5899612/remote/gibba025/log/ceph-mon.a.log.gz

regression caused by 725a4b8b42f7cb03138cc1fa950b160abdd52125


Related issues

Copied to CephFS - Backport #49569: pacific: qa: rank_freeze prevents failover on some tests Resolved

History

#1 Updated by Patrick Donnelly about 2 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 39679

#2 Updated by Patrick Donnelly about 2 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Backport Bot about 2 months ago

  • Copied to Backport #49569: pacific: qa: rank_freeze prevents failover on some tests added

#4 Updated by Loïc Dachary 19 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF