Project

General

Profile

Bug #4915

tasks using ceph-deploy on configurations with 2 monitors per host sometimes report passing

Added by Greg Farnum over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
05/06/2013
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Tamil tells me that the ceph-deploy stuff doesn't support multiple monitors on a host, for reasons that I don't really understand. However, we've had a task running in the fs nightlies since early March that has that configuration, and it's only started failing in the last 3 days. Figure out why it's been passing.

Hopefully we can also fix up the ceph-deploy stuff so that that will succeed?

History

#1 Updated by Anonymous over 6 years ago

  • Priority changed from Normal to High

#2 Updated by Tamilarasi muthamizhan over 6 years ago

  • Status changed from New to Resolved

bug: 4952 explains this.

hey Greg, please ignore my comment about running 2 monitors on the same host being reason for that failure. while ceph-deploy still creates only one monitor per node, it doesn't fail or misbehave when tried with 2 monitors on the same node :)

Also available in: Atom PDF