Project

General

Profile

Bug #49115

[rbd-mirror] image rename might not be propagated under snapshot-based mode

Added by Jason Dillaman 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
octopus,pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If the exclusive-lock is enabled, the rename might be executed by short-life client A while long-life client B might acquire the exclusive-lock and actually create a mirror snapshot. In this case, if client B has had the image open since before client A renamed the image, it will not properly write the new image in the ImageState structure.


Related issues

Copied to rbd - Backport #49454: octopus: [rbd-mirror] image rename might not be propagated under snapshot-based mode Resolved
Copied to rbd - Backport #49455: pacific: [rbd-mirror] image rename might not be propagated under snapshot-based mode Resolved

History

#1 Updated by Mykola Golub 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Mykola Golub

#2 Updated by Mykola Golub 4 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 39463

#3 Updated by Jason Dillaman 4 months ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot 4 months ago

  • Copied to Backport #49454: octopus: [rbd-mirror] image rename might not be propagated under snapshot-based mode added

#5 Updated by Backport Bot 4 months ago

  • Copied to Backport #49455: pacific: [rbd-mirror] image rename might not be propagated under snapshot-based mode added

#6 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF