Project

General

Profile

Bug #4911

rbd: revalidate only for mapping size changes

Added by Alex Elder almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

This commit:
d98df63e rbd: revalidate_disk upon rbd resize
instituted a call to revalidate_disk() to notify interested parties
that a mapped image has changed size. This works well, as long as
the the rbd device doesn't map a snapshot.

A snapshot will never change size. However, the base image the
snapshot is associated with can, and it can do so while the snapshot
is mapped.

The problem is that the test for the size is looking at the size of
the base image, not the size of the mapped snapshot. This patch
corrects that.

Update the warning message shown in the event of error, and move
it into the callers.

Signed-off-by: Alex Elder <>

History

#1 Updated by Alex Elder almost 7 years ago

  • Status changed from In Progress to Fix Under Review

The following has been posted for review:

[PATCH] rbd: revalidate only for mapping size changes

#2 Updated by Alex Elder almost 7 years ago

  • Status changed from Fix Under Review to Resolved

The following has been committed to the "testing-next"
branch of the ceph-client git repository. I am holding
off committing it to "testing" until after the Linux 3.10
merge window closes, as requested by Stephen Rothwell
(who does linux-next).

e627db08 rbd: revalidate only for mapping size changes

Also available in: Atom PDF