Project

General

Profile

Bug #49080

packages fail to install on Fedora 34/rawhide due to missing shared lib libblk.so

Added by Kaleb KEITHLEY 24 days ago. Updated 7 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
build
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

see https://bugzilla.redhat.com/show_bug.cgi?id=1923069

cmake library targets default to shared libs, but libblk.so is apparently an internal build artifact that isn't intended to be shipped.

I fixed this with:
--- ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt.orig 2021-02-01 08:16:26.719517641 -0500
+++ ceph-16.1.0-43-g6b74fb5c/src/blk/CMakeLists.txt 2021-02-01 08:16:47.810092341 -0500
@ -25,7 +25,7 @
zoned/HMSMRDevice.cc)
endif()

-add_library(blk ${libblk_srcs})
+add_library(blk STATIC ${libblk_srcs})
target_include_directories(blk PRIVATE "./")

if(HAVE_LIBAIO)

Related issues

Duplicates Ceph - Bug #38611: building libcrc32 Pending Backport

History

#1 Updated by Kefu Chai 7 days ago

#2 Updated by Kefu Chai 7 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF